# GHSA-qxh3-jgvh-x55j: Connect-CMS Privilege Escalation Vulnerability

> Attackers can escalate privileges in Connect-CMS management system, requiring an upgrade to the latest version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2023

## What is GHSA-qxh3-jgvh-x55j?

GHSA-qxh3-jgvh-x55j is a vulnerability in opensource-workshop/connect-cms, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact（影響）

There is a Privilege Escalation Vulnerability on the management system of Connect-CMS.
Affercted Version : Connect-CMS 1.7.1, 2.3.1 and earlier

### Patches（修正バージョン）

version 1.7.2, 2.3.1

### Workarounds（運用回避手段）

Upgrade Connect-CMS to latest version

## Which versions are affected by GHSA-qxh3-jgvh-x55j?

4 open source packages ship an affected version, including opensource-workshop/connect-cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.7.2 |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.7.2 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.3.2 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.3.2 |

## How do I fix GHSA-qxh3-jgvh-x55j?

Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.7.2 or 2.3.2.

## Is GHSA-qxh3-jgvh-x55j being exploited?

There is no known exploitation of GHSA-qxh3-jgvh-x55j in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-qxh3-jgvh-x55j and fix it if it is affected.

What it is: GHSA-qxh3-jgvh-x55j is a vulnerability in opensource-workshop/connect-cms, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qxh3-jgvh-x55j in the wild and no public exploit code.

Affected packages and fixed versions:
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.7.2
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.7.2
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.3.2
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/ (Markdown: https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-qxh3-jgvh-x55j

---
From sbomify Insights: https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/
Summaries are generated and may contain mistakes; the official description above is the record.
