{"answers":{"affected":"3 open source packages ship an affected version, including unsafe-libyaml.","exploited":"There is no known exploitation of GHSA-r24f-hg58-vfrw in the wild and no public exploit code.","fix":"Upgrade unsafe-libyaml to 0.2.10 or later.","what":"GHSA-r24f-hg58-vfrw is a memory corruption vulnerability in unsafe-libyaml, published on 20 Dec 2023."},"fix_prompt":"Check this codebase for GHSA-r24f-hg58-vfrw and fix it if it is affected.\n\nWhat it is: GHSA-r24f-hg58-vfrw is a memory corruption vulnerability in unsafe-libyaml, published on 20 Dec 2023. \nExploitation: There is no known exploitation of GHSA-r24f-hg58-vfrw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- unsafe-libyaml (crates.io): affected all versions; fixed in 0.2.10\n- unsafe-libyaml (crates.io): affected all versions; fixed in 0.2.10\n- unsafe-libyaml (crates.io): affected from 0.0.0-0; fixed in 0.2.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-r24f-hg58-vfrw/ (Markdown: https://insights.sbomify.com/GHSA-r24f-hg58-vfrw/index.md)","id":"GHSA-r24f-hg58-vfrw","markdown":"https://insights.sbomify.com/GHSA-r24f-hg58-vfrw/index.md","name":"GHSA-r24f-hg58-vfrw","record":{"aliases":["RUSTSEC-2023-0075"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust YAML library","requires_auth":"none","summary":"An attacker can cause a crash in unsafe-libyaml on 32-bit or 16-bit platforms due to unaligned memory writes, leading to denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions allocate memory using the alignment of `usize` and write data to it of type `u64`, without using `core::ptr::write_unaligned`. In platforms with sub-64bit alignment for `usize` (including wasm32 and x86) these writes are insufficiently aligned some of the time.\n\nIf using an ordinary optimized standard library, the bug exhibits Undefined Behavior so may or may not behave in any sensible way, depending on optimization settings and hardware and other things. If using a Rust standard library built with debug assertions enabled, the bug manifests deterministically in a crash (non-unwinding panic) saying _\"ptr::write requires that the pointer argument is aligned and non-null\"_.\n\nNo 64-bit platform is impacted by the bug.\n\nThe flaw was corrected by allocating with adequately high alignment on all\nplatforms.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"unsafe-libyaml unaligned write of u64 on 32-bit and 16-bit platforms","id":"GHSA-r24f-hg58-vfrw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.2.10"],"introduced":["0"],"last_affected":[],"package":"unsafe-libyaml","purl":null,"source":"GHSA-r24f-hg58-vfrw"},{"ecosystem":"crates.io","fixed":["0.2.10"],"introduced":["0"],"last_affected":[],"package":"unsafe-libyaml","purl":"pkg:cargo/unsafe-libyaml","source":"GHSA-r24f-hg58-vfrw"},{"ecosystem":"crates.io","fixed":["0.2.10"],"introduced":["0.0.0-0"],"last_affected":[],"package":"unsafe-libyaml","purl":"pkg:cargo/unsafe-libyaml","source":"RUSTSEC-2023-0075"}],"products":null,"published":"2023-12-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a crash in unsafe-libyaml on 32-bit or 16-bit platforms due to unaligned memory writes, leading to denial of service.","url":"https://insights.sbomify.com/GHSA-r24f-hg58-vfrw/"}