{"answers":{"affected":"4 open source packages ship an affected version, including nzo/url-encryptor-bundle.","exploited":"There is no known exploitation of GHSA-r2r8-36pq-27cm in the wild and no public exploit code.","fix":"Upgrade nzo/url-encryptor-bundle to a fixed version for your release line: 4.3.2 or 5.0.1.","what":"GHSA-r2r8-36pq-27cm is a vulnerability in nzo/url-encryptor-bundle, published on 17 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-r2r8-36pq-27cm and fix it if it is affected.\n\nWhat it is: GHSA-r2r8-36pq-27cm is a vulnerability in nzo/url-encryptor-bundle, published on 17 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-r2r8-36pq-27cm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nzo/url-encryptor-bundle (Packagist): affected from 4.0.0; fixed in 4.3.2\n- nzo/url-encryptor-bundle (Packagist): affected from 4.0.0; fixed in 4.3.2\n- nzo/url-encryptor-bundle (Packagist): affected from 5.0.0; fixed in 5.0.1\n- nzo/url-encryptor-bundle (Packagist): affected from 5.0.0; fixed in 5.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-r2r8-36pq-27cm/ (Markdown: https://insights.sbomify.com/GHSA-r2r8-36pq-27cm/index.md)","id":"GHSA-r2r8-36pq-27cm","markdown":"https://insights.sbomify.com/GHSA-r2r8-36pq-27cm/index.md","name":"GHSA-r2r8-36pq-27cm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP URL encryption library","requires_auth":"none","summary":"An attacker can decrypt and modify encrypted data due to insecure default cryptographic settings in the URL encryptor bundle.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of nzo/url-encryptor-bundle prior to 5.0.1 and 4.3.2 are affected by a security vulnerability related to the lack of mandatory key and IV requirements. By default, the bundle uses the aes-256-ctr algorithm, which is susceptible to malleability attacks, potentially leading to Insecure Direct Object Reference (IDOR) vulnerabilities. Additionally, the reuse of keys enables users to decrypt and modify encrypted data if they can guess the plaintext of one ciphertext.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"nzo/url-encryptor-bundle Insecure default secret key and IV allowing anyone to decrypt values","id":"GHSA-r2r8-36pq-27cm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.3.2"],"introduced":["4.0.0"],"last_affected":[],"package":"nzo/url-encryptor-bundle","purl":null,"source":"GHSA-r2r8-36pq-27cm"},{"ecosystem":"Packagist","fixed":["4.3.2"],"introduced":["4.0.0"],"last_affected":[],"package":"nzo/url-encryptor-bundle","purl":"pkg:composer/nzo/url-encryptor-bundle","source":"GHSA-r2r8-36pq-27cm"},{"ecosystem":"Packagist","fixed":["5.0.1"],"introduced":["5.0.0"],"last_affected":[],"package":"nzo/url-encryptor-bundle","purl":null,"source":"GHSA-r2r8-36pq-27cm"},{"ecosystem":"Packagist","fixed":["5.0.1"],"introduced":["5.0.0"],"last_affected":[],"package":"nzo/url-encryptor-bundle","purl":"pkg:composer/nzo/url-encryptor-bundle","source":"GHSA-r2r8-36pq-27cm"}],"products":null,"published":"2024-05-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can decrypt and modify encrypted data due to insecure default cryptographic settings in the URL encryptor bundle.","url":"https://insights.sbomify.com/GHSA-r2r8-36pq-27cm/"}