GHSA-r3xc-47qg-h929 Cross-Site Scripting in @ionic/core
Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized input in specific Ionic components.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-r3xc-47qg-h929?
GHSA-r3xc-47qg-h929 is a cross-site scripting vulnerability in @ionic/core, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Versions of @ionic/core prior to 4.0.3, 4.1.3, 4.2.1 or 4.3.1 are vulnerable to Cross-Site Scripting (XSS). The package uses the unsafe innerHTML function without sanitizing input, which may allow attackers to execute arbitrary JavaScript on the victim's browser. This issue affects the components:
<ion-alert>.message<ion-searchbar>.placeholder<ion-infinite-scroll-content>.loadingText<ion-refresher-content>.pullingText<ion-refresher-content>.refershingText
Recommendation
- If you are using @ionic/core 4.0.x, upgrade to 4.0.3 or later.
- If you are using @ionic/core 4.1.x, upgrade to 4.1.3 or later.
- If you are using @ionic/core 4.2.x, upgrade to 4.2.1 or later.
- If you are using @ionic/core 4.3.x, upgrade to 4.3.1 or later.
Which versions are affected by GHSA-r3xc-47qg-h929?
8 open source packages ship an affected version, including @ionic/core.
| Package | Affected | Fixed in |
|---|---|---|
@ionic/core npm | All versions | 4.0.3 |
@ionic/core npm | All versions | 4.0.3 |
@ionic/core npm | From 4.1.0 | 4.1.3 |
@ionic/core npm | From 4.1.0 | 4.1.3 |
@ionic/core npm | From 4.2.0 | 4.2.1 |
@ionic/core npm | From 4.2.0 | 4.2.1 |
2 more packages
@ionic/core npm | From 4.3.0 | 4.3.1 |
@ionic/core npm | From 4.3.0 | 4.3.1 |
How do I fix GHSA-r3xc-47qg-h929?
Upgrade @ionic/core to a fixed version for your release line: 4.0.3, 4.1.3, 4.2.1 or 4.3.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-r3xc-47qg-h929 being exploited?
There is no known exploitation of GHSA-r3xc-47qg-h929 in the wild and no public exploit code.