{"answers":{"affected":"6 open source packages ship an affected version, including ftp-srv.","exploited":"There is no known exploitation of GHSA-r4m5-47cq-6qg8 in the wild and no public exploit code.","fix":"Upgrade ftp-srv to a fixed version for your release line: 2.19.6, 3.1.2 or 4.3.4.","what":"GHSA-r4m5-47cq-6qg8 is a server-side request forgery vulnerability in ftp-srv, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-r4m5-47cq-6qg8 and fix it if it is affected.\n\nWhat it is: GHSA-r4m5-47cq-6qg8 is a server-side request forgery vulnerability in ftp-srv, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-r4m5-47cq-6qg8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6\n- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6\n- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2\n- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2\n- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4\n- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/ (Markdown: https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/index.md)","id":"GHSA-r4m5-47cq-6qg8","markdown":"https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/index.md","name":"GHSA-r4m5-47cq-6qg8","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js FTP server","requires_auth":"none","summary":"Attackers can exploit SSRF in ftp-srv to access private network resources via the PORT command, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"All versions of `ftp-srv` from v1.0.0 onward to v4.3.3 are vulnerable to Server-Side Request Forgery (SSRF). The package fails to prevent remote clients to access other resources in the network, for example when connecting to the server through telnet. This allows attackers to access any network resources available to the server, including private resources in the hosting environment.\n\n## Recommendation\n\nUpgrade to patched versions\n`^2.19.6, ^3.1.2, ^4.3.4`\n\n## Workarounds\nBlacklisting the FTP Command PORT will prevent the server from exposing this behaviour through active connections until a fix is applied.\n\n```\nconst ftp = new FtpSrv({\n  blacklist: ['PORT']\n});\n```","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Server-Side Request Forgery in ftp-srv","id":"GHSA-r4m5-47cq-6qg8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2020"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.19.6"],"introduced":["1.0.0"],"last_affected":[],"package":"ftp-srv","purl":null,"source":"GHSA-r4m5-47cq-6qg8"},{"ecosystem":"npm","fixed":["2.19.6"],"introduced":["1.0.0"],"last_affected":[],"package":"ftp-srv","purl":"pkg:npm/ftp-srv","source":"GHSA-r4m5-47cq-6qg8"},{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["3.0.0"],"last_affected":[],"package":"ftp-srv","purl":null,"source":"GHSA-r4m5-47cq-6qg8"},{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["3.0.0"],"last_affected":[],"package":"ftp-srv","purl":"pkg:npm/ftp-srv","source":"GHSA-r4m5-47cq-6qg8"},{"ecosystem":"npm","fixed":["4.3.4"],"introduced":["4.0.0"],"last_affected":[],"package":"ftp-srv","purl":null,"source":"GHSA-r4m5-47cq-6qg8"},{"ecosystem":"npm","fixed":["4.3.4"],"introduced":["4.0.0"],"last_affected":[],"package":"ftp-srv","purl":"pkg:npm/ftp-srv","source":"GHSA-r4m5-47cq-6qg8"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit SSRF in ftp-srv to access private network resources via the PORT command, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/"}