# GHSA-r4m5-47cq-6qg8: Server-Side Request Forgery in ftp-srv

> Attackers can exploit SSRF in ftp-srv to access private network resources via the PORT command, requiring an upgrade to patched versions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2020

## What is GHSA-r4m5-47cq-6qg8?

GHSA-r4m5-47cq-6qg8 is a server-side request forgery vulnerability in ftp-srv, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of `ftp-srv` from v1.0.0 onward to v4.3.3 are vulnerable to Server-Side Request Forgery (SSRF). The package fails to prevent remote clients to access other resources in the network, for example when connecting to the server through telnet. This allows attackers to access any network resources available to the server, including private resources in the hosting environment.

## Recommendation

Upgrade to patched versions
`^2.19.6, ^3.1.2, ^4.3.4`

## Workarounds
Blacklisting the FTP Command PORT will prevent the server from exposing this behaviour through active connections until a fix is applied.

```
const ftp = new FtpSrv({
  blacklist: ['PORT']
});
```

## Which versions are affected by GHSA-r4m5-47cq-6qg8?

6 open source packages ship an affected version, including ftp-srv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ftp-srv` | npm | From 1.0.0 | 2.19.6 |
| `ftp-srv` | npm | From 1.0.0 | 2.19.6 |
| `ftp-srv` | npm | From 3.0.0 | 3.1.2 |
| `ftp-srv` | npm | From 3.0.0 | 3.1.2 |
| `ftp-srv` | npm | From 4.0.0 | 4.3.4 |
| `ftp-srv` | npm | From 4.0.0 | 4.3.4 |

## How do I fix GHSA-r4m5-47cq-6qg8?

Upgrade ftp-srv to a fixed version for your release line: 2.19.6, 3.1.2 or 4.3.4.

## Is GHSA-r4m5-47cq-6qg8 being exploited?

There is no known exploitation of GHSA-r4m5-47cq-6qg8 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-r4m5-47cq-6qg8 and fix it if it is affected.

What it is: GHSA-r4m5-47cq-6qg8 is a server-side request forgery vulnerability in ftp-srv, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-r4m5-47cq-6qg8 in the wild and no public exploit code.

Affected packages and fixed versions:
- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6
- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6
- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2
- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2
- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4
- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/ (Markdown: https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-r4m5-47cq-6qg8

---
From sbomify Insights: https://insights.sbomify.com/GHSA-r4m5-47cq-6qg8/
Summaries are generated and may contain mistakes; the official description above is the record.
