{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui.","exploited":"There is no known exploitation of GHSA-r7pm-mw8g-p7px in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezplatform-admin-ui to 2.3.38 or later.","what":"GHSA-r7pm-mw8g-p7px is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-r7pm-mw8g-p7px and fix it if it is affected.\n\nWhat it is: GHSA-r7pm-mw8g-p7px is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-r7pm-mw8g-p7px in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 2.3.0-beta1; fixed in 2.3.38\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 2.3.0-beta1; fixed in 2.3.38\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-r7pm-mw8g-p7px/ (Markdown: https://insights.sbomify.com/GHSA-r7pm-mw8g-p7px/index.md)","id":"GHSA-r7pm-mw8g-p7px","markdown":"https://insights.sbomify.com/GHSA-r7pm-mw8g-p7px/index.md","name":"GHSA-r7pm-mw8g-p7px","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ibexa DXP Admin UI","requires_auth":"low_privilege","summary":"Persistent XSS in Ibexa DXP back office allows low-privilege users to inject scripts affecting end users, requiring patching.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThis security advisory is a part of IBEXA-SA-2025-003, which resolves XSS vulnerabilities in several parts of the back office of Ibexa DXP. Back office access and varying levels of editing and management permissions are required to exploit these vulnerabilities. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and can be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless.\n\n### Patches\n- See \"Patched versions\".\n- https://github.com/ezsystems/ezplatform-admin-ui/commit/acaa620d4ef44e7c20908dc389d48064f2c19e6d\n\n### Workarounds\nNone.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Ibexa eZ Platform Admin UI XSS vulnerabilities in back office","id":"GHSA-r7pm-mw8g-p7px","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.3.38"],"introduced":["2.3.0-beta1"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":null,"source":"GHSA-r7pm-mw8g-p7px"},{"ecosystem":"Packagist","fixed":["2.3.38"],"introduced":["2.3.0-beta1"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":"pkg:composer/ezsystems/ezplatform-admin-ui","source":"GHSA-r7pm-mw8g-p7px"}],"products":null,"published":"2025-06-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Persistent XSS in Ibexa DXP back office allows low-privilege users to inject scripts affecting end users, requiring patching.","url":"https://insights.sbomify.com/GHSA-r7pm-mw8g-p7px/"}