{"answers":{"affected":"2 open source packages ship an affected version, including google-closure-library.","exploited":"There is no known exploitation of GHSA-r9q4-w3fm-wrm2 in the wild and no public exploit code.","fix":"Upgrade google-closure-library to 20190301.0.0 or later.","what":"GHSA-r9q4-w3fm-wrm2 is a cross-site scripting vulnerability in google-closure-library, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-r9q4-w3fm-wrm2 and fix it if it is affected.\n\nWhat it is: GHSA-r9q4-w3fm-wrm2 is a cross-site scripting vulnerability in google-closure-library, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-r9q4-w3fm-wrm2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- google-closure-library (npm): affected all versions; fixed in 20190301.0.0\n- google-closure-library (npm): affected all versions; fixed in 20190301.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-r9q4-w3fm-wrm2/ (Markdown: https://insights.sbomify.com/GHSA-r9q4-w3fm-wrm2/index.md)","id":"GHSA-r9q4-w3fm-wrm2","markdown":"https://insights.sbomify.com/GHSA-r9q4-w3fm-wrm2/index.md","name":"GHSA-r9q4-w3fm-wrm2","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via Mutation XSS in google-closure-library, requiring user interaction to trigger the vulnerability.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `google-closure-library` prior to 20190301.0.0 are vulnerable to Cross-Site Scripting. The `safedomtreeprocessor.processToString()` function improperly processed empty elements, which could allow attackers to execute arbitrary JavaScript through Mutation Cross-Site Scripting.\n\n## Recommendation\n\nUpgrade to version 20190301.0.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in google-closure-library","id":"GHSA-r9q4-w3fm-wrm2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["20190301.0.0"],"introduced":["0"],"last_affected":[],"package":"google-closure-library","purl":null,"source":"GHSA-r9q4-w3fm-wrm2"},{"ecosystem":"npm","fixed":["20190301.0.0"],"introduced":["0"],"last_affected":[],"package":"google-closure-library","purl":"pkg:npm/google-closure-library","source":"GHSA-r9q4-w3fm-wrm2"}],"products":null,"published":"2020-09-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript via Mutation XSS in google-closure-library, requiring user interaction to trigger the vulnerability.","url":"https://insights.sbomify.com/GHSA-r9q4-w3fm-wrm2/"}