{"answers":{"affected":"2 open source packages ship an affected version, including fastmcp.","exploited":"There is no known exploitation of GHSA-rcfx-77hg-w2wv in the wild and no public exploit code.","fix":"Upgrade fastmcp to 2.14.0 or later.","what":"GHSA-rcfx-77hg-w2wv is a vulnerability in fastmcp, published on 26 Dec 2025."},"fix_prompt":"Check this codebase for GHSA-rcfx-77hg-w2wv and fix it if it is affected.\n\nWhat it is: GHSA-rcfx-77hg-w2wv is a vulnerability in fastmcp, published on 26 Dec 2025. \nExploitation: There is no known exploitation of GHSA-rcfx-77hg-w2wv in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastmcp (PyPI): affected all versions; fixed in 2.14.0\n- fastmcp (PyPI): affected all versions; fixed in 2.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rcfx-77hg-w2wv/ (Markdown: https://insights.sbomify.com/GHSA-rcfx-77hg-w2wv/index.md)","id":"GHSA-rcfx-77hg-w2wv","markdown":"https://insights.sbomify.com/GHSA-rcfx-77hg-w2wv/index.md","name":"GHSA-rcfx-77hg-w2wv","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"unknown","non_default_config":false,"product_category":"Python MCP library","requires_auth":"unknown","summary":"FastMCP allowed vulnerable MCP SDK versions, requiring an upgrade to mitigate risks from CVE-2025-66416.","user_interaction":"unknown","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"There was a recent CVE report on MCP: https://nvd.nist.gov/vuln/detail/CVE-2025-66416. \n\nFastMCP does not use any of the affected components of the MCP SDK directly. However, FastMCP versions prior to 2.14.0 did allow MCP SDK versions \u003c1.23 that were vulnerable to CVE-2025-66416. Users should upgrade to FastMCP 2.14.0 or later.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"FastMCP updated to MCP 1.23+ due to CVE-2025-66416","id":"GHSA-rcfx-77hg-w2wv","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":null,"source":"GHSA-rcfx-77hg-w2wv"},{"ecosystem":"PyPI","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":"pkg:pypi/fastmcp","source":"GHSA-rcfx-77hg-w2wv"}],"products":null,"published":"2025-12-26","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"FastMCP allowed vulnerable MCP SDK versions, requiring an upgrade to mitigate risks from CVE-2025-66416.","url":"https://insights.sbomify.com/GHSA-rcfx-77hg-w2wv/"}