{"answers":{"affected":"2 open source packages ship an affected version, including zfr/zfr-oauth2-server-module.","exploited":"There is no known exploitation of GHSA-rcm4-jv5g-wccm in the wild and no public exploit code.","fix":"Upgrade zfr/zfr-oauth2-server-module to 0.1.2 or later.","what":"GHSA-rcm4-jv5g-wccm is an authentication bypass vulnerability in zfr/zfr-oauth2-server-module, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rcm4-jv5g-wccm and fix it if it is affected.\n\nWhat it is: GHSA-rcm4-jv5g-wccm is an authentication bypass vulnerability in zfr/zfr-oauth2-server-module, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rcm4-jv5g-wccm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zfr/zfr-oauth2-server-module (Packagist): affected all versions; fixed in 0.1.2\n- zfr/zfr-oauth2-server-module (Packagist): affected all versions; fixed in 0.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rcm4-jv5g-wccm/ (Markdown: https://insights.sbomify.com/GHSA-rcm4-jv5g-wccm/index.md)","id":"GHSA-rcm4-jv5g-wccm","markdown":"https://insights.sbomify.com/GHSA-rcm4-jv5g-wccm/index.md","name":"GHSA-rcm4-jv5g-wccm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP OAuth2 library","requires_auth":"none","summary":"An authentication adapter failed to verify token validity, allowing attackers to use expired tokens to bypass authentication controls.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Previous to @2ca5bb1c2f11537be8f94ca6867d8d69789e744a (release [0.1.2](https://github.com/zf-fr/zfr-oauth2-server-module/tree/0.1.2)), tokens weren't checked for validity/expiration.\n\nThis potentially caused a security issue if expired tokens were not deleted after the expiration time was past, allowing anyone to still use invalidated authentication credentials.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"zfr authentication adapter did not verify validity of tokens","id":"GHSA-rcm4-jv5g-wccm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"zfr/zfr-oauth2-server-module","purl":null,"source":"GHSA-rcm4-jv5g-wccm"},{"ecosystem":"Packagist","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"zfr/zfr-oauth2-server-module","purl":"pkg:composer/zfr/zfr-oauth2-server-module","source":"GHSA-rcm4-jv5g-wccm"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An authentication adapter failed to verify token validity, allowing attackers to use expired tokens to bypass authentication controls.","url":"https://insights.sbomify.com/GHSA-rcm4-jv5g-wccm/"}