{"answers":{"affected":"2 open source packages ship an affected version, including s2n-quic.","exploited":"There is no known exploitation of GHSA-rfhg-rjfp-9q8q in the wild and no public exploit code.","fix":"Upgrade s2n-quic to 1.25.0 or later.","what":"GHSA-rfhg-rjfp-9q8q is a denial of service vulnerability in s2n-quic, published on 24 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rfhg-rjfp-9q8q and fix it if it is affected.\n\nWhat it is: GHSA-rfhg-rjfp-9q8q is a denial of service vulnerability in s2n-quic, published on 24 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rfhg-rjfp-9q8q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- s2n-quic (crates.io): affected all versions; fixed in 1.25.0\n- s2n-quic (crates.io): affected all versions; fixed in 1.25.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rfhg-rjfp-9q8q/ (Markdown: https://insights.sbomify.com/GHSA-rfhg-rjfp-9q8q/index.md)","id":"GHSA-rfhg-rjfp-9q8q","markdown":"https://insights.sbomify.com/GHSA-rfhg-rjfp-9q8q/index.md","name":"GHSA-rfhg-rjfp-9q8q","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"QUIC protocol library","requires_auth":"none","summary":"A remote attacker can cause a denial of service in applications using the s2n-quic library by triggering connection migration with duplicate frames.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAn issue in s2n-quic results in the endpoint shutting down due to a combination of peer-initiated connection migration and duplicate new connection ID frames being received. No AWS services are affected by this issue, and customers of AWS services do not need to take action.\n\nImpacted versions: \u003c=v1.24.0\n### Patches\nThe patch is included in v1.25.0.\n\n### Workarounds\nThere is no workaround. Applications using s2n-quic should upgrade their application to the most recent release of s2n-quic.\n\nIf you have any questions or comments about this advisory we ask that you contact AWS/Amazon Security via our vulnerability reporting page or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Potential denial of service after connection migration","id":"GHSA-rfhg-rjfp-9q8q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["1.25.0"],"introduced":["0"],"last_affected":[],"package":"s2n-quic","purl":null,"source":"GHSA-rfhg-rjfp-9q8q"},{"ecosystem":"crates.io","fixed":["1.25.0"],"introduced":["0"],"last_affected":[],"package":"s2n-quic","purl":"pkg:cargo/s2n-quic","source":"GHSA-rfhg-rjfp-9q8q"}],"products":null,"published":"2023-07-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A remote attacker can cause a denial of service in applications using the s2n-quic library by triggering connection migration with duplicate frames.","url":"https://insights.sbomify.com/GHSA-rfhg-rjfp-9q8q/"}