{"answers":{"affected":"3 open source packages ship an affected version, including postgres-protocol.","exploited":"There is no known exploitation of GHSA-rgqc-3x5p-6gwg in the wild and no public exploit code.","fix":"Upgrade postgres-protocol to 0.6.12 or later.","what":"GHSA-rgqc-3x5p-6gwg is a denial of service vulnerability in postgres-protocol, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rgqc-3x5p-6gwg and fix it if it is affected.\n\nWhat it is: GHSA-rgqc-3x5p-6gwg is a denial of service vulnerability in postgres-protocol, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rgqc-3x5p-6gwg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgres-protocol (crates.io): affected all versions; fixed in 0.6.12\n- postgres-protocol (crates.io): affected all versions; fixed in 0.6.12\n- postgres-protocol (crates.io): affected from 0.0.0-0; fixed in 0.6.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rgqc-3x5p-6gwg/ (Markdown: https://insights.sbomify.com/GHSA-rgqc-3x5p-6gwg/index.md)","id":"GHSA-rgqc-3x5p-6gwg","markdown":"https://insights.sbomify.com/GHSA-rgqc-3x5p-6gwg/index.md","name":"GHSA-rgqc-3x5p-6gwg","record":{"aliases":["RUSTSEC-2026-0180"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust postgres client","requires_auth":"none","summary":"A malicious server can cause a Rust postgres client to panic and crash by sending a malformed hstore value, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A malicious or compromised server can return a binary `hstore` value with an\ninvalid internal length field, causing the client to panic while decoding it.\n\nApplications that connect only to a trusted database are not exposed; the risk\napplies to clients that may connect to untrusted or user-supplied servers, or\nwhose connection can be intercepted by a man-in-the-middle.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"postgres-protocol: Panic decoding a malformed `hstore` value allows denial of service","id":"GHSA-rgqc-3x5p-6gwg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.6.12"],"introduced":["0"],"last_affected":[],"package":"postgres-protocol","purl":null,"source":"GHSA-rgqc-3x5p-6gwg"},{"ecosystem":"crates.io","fixed":["0.6.12"],"introduced":["0"],"last_affected":[],"package":"postgres-protocol","purl":"pkg:cargo/postgres-protocol","source":"GHSA-rgqc-3x5p-6gwg"},{"ecosystem":"crates.io","fixed":["0.6.12"],"introduced":["0.0.0-0"],"last_affected":[],"package":"postgres-protocol","purl":"pkg:cargo/postgres-protocol","source":"RUSTSEC-2026-0180"}],"products":null,"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious server can cause a Rust postgres client to panic and crash by sending a malformed hstore value, leading to denial of service.","url":"https://insights.sbomify.com/GHSA-rgqc-3x5p-6gwg/"}