{"answers":{"affected":"2 open source packages ship an affected version, including @commercial/ammo.","exploited":"There is no known exploitation of GHSA-rhc3-76jw-4f2x in the wild and no public exploit code.","fix":"Upgrade @commercial/ammo to 2.1.1 or later.","what":"GHSA-rhc3-76jw-4f2x is a denial of service vulnerability in @commercial/ammo, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rhc3-76jw-4f2x and fix it if it is affected.\n\nWhat it is: GHSA-rhc3-76jw-4f2x is a denial of service vulnerability in @commercial/ammo, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rhc3-76jw-4f2x in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @commercial/ammo (npm): affected all versions; fixed in 2.1.1\n- @commercial/ammo (npm): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rhc3-76jw-4f2x/ (Markdown: https://insights.sbomify.com/GHSA-rhc3-76jw-4f2x/index.md)","id":"GHSA-rhc3-76jw-4f2x","markdown":"https://insights.sbomify.com/GHSA-rhc3-76jw-4f2x/index.md","name":"GHSA-rhc3-76jw-4f2x","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP library","requires_auth":"none","summary":"An attacker can crash the application by sending a malformed Range HTTP header, causing an unhandled exception in the @commercial/ammo library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `@commercial/ammo` prior to 2.1.1 are vulnerable to Denial of Service. The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.\n\n## Recommendation\n\nUpgrade to version 2.1.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in @commercial/ammo","id":"GHSA-rhc3-76jw-4f2x","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"@commercial/ammo","purl":null,"source":"GHSA-rhc3-76jw-4f2x"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"@commercial/ammo","purl":"pkg:npm/%40commercial/ammo","source":"GHSA-rhc3-76jw-4f2x"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash the application by sending a malformed Range HTTP header, causing an unhandled exception in the @commercial/ammo library.","url":"https://insights.sbomify.com/GHSA-rhc3-76jw-4f2x/"}