# GHSA-rj53-j6jw-7f7g: Babylon vulnerable to chain halt when a message modifies the validator set at the epoch boundary

> An attacker can halt the blockchain by sending a message that modifies the validator set at the epoch boundary, causing a panic.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Also known as:** GO-2025-3801

## What is GHSA-rj53-j6jw-7f7g?

GHSA-rj53-j6jw-7f7g is a denial of service vulnerability in github.com/babylonlabs-io/babylon, published on 8 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Summary

Sending a message that modifies the validator set at the epoch boundary halts the chain.

### Impact

Denial of Service - Comos-sdk prevents modifying the validator set from two different modules - https://github.com/cosmos/cosmos-sdk/blob/release/v0.50.x/types/module/module.go#L811. Such an operation leads to panic and chain halt.

### Detailed Post mortem

https://boiling-lake-106.notion.site/2025-06-18-Genesis-mainnet-chain-halt-post-mortem-229f60cc1b5f80b7adf5e3ea0541ea87

## Which versions are affected by GHSA-rj53-j6jw-7f7g?

4 open source packages ship an affected version, including github.com/babylonlabs-io/babylon/v2 and github.com/babylonlabs-io/babylon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/babylonlabs-io/babylon/v2` | Go | From 2.0.0 | 2.1.0 |
| `github.com/babylonlabs-io/babylon/v2` | Go | From 2.0.0 | 2.1.0 |
| `github.com/babylonlabs-io/babylon/v2` | Go | From 2.0.0 | 2.1.0 |
| `github.com/babylonlabs-io/babylon` | Go | All versions | None |

## How do I fix GHSA-rj53-j6jw-7f7g?

Upgrade github.com/babylonlabs-io/babylon/v2 to 2.1.0 or later.

## Is GHSA-rj53-j6jw-7f7g being exploited?

There is no known exploitation of GHSA-rj53-j6jw-7f7g in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-rj53-j6jw-7f7g and fix it if it is affected.

What it is: GHSA-rj53-j6jw-7f7g is a denial of service vulnerability in github.com/babylonlabs-io/babylon, published on 8 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-rj53-j6jw-7f7g in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/babylonlabs-io/babylon/v2 (Go): affected from 2.0.0; fixed in 2.1.0
- github.com/babylonlabs-io/babylon/v2 (Go): affected from 2.0.0; fixed in 2.1.0
- github.com/babylonlabs-io/babylon/v2 (Go): affected from 2.0.0; fixed in 2.1.0
- github.com/babylonlabs-io/babylon (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-rj53-j6jw-7f7g/ (Markdown: https://insights.sbomify.com/GHSA-rj53-j6jw-7f7g/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-rj53-j6jw-7f7g

---
From sbomify Insights: https://insights.sbomify.com/GHSA-rj53-j6jw-7f7g/
Summaries are generated and may contain mistakes; the official description above is the record.
