# GHSA-rm89-9g65-4ffr: Insufficient HTML Sanitization

> Authenticated users can inject malicious JavaScript into the InvenTree web interface due to insufficient HTML sanitization, potentially compromising other users.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2022

## What is GHSA-rm89-9g65-4ffr?

GHSA-rm89-9g65-4ffr is a cross-site scripting vulnerability in inventree, published on 17 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact

Affected versions can have malicious javascript code injected into the users browser by other authenticated users, as data fields retrieved from the database are not properly sanitized before displaying in various front-end views.

The problem here stems from multiple issues:

- Insufficient database sanitation on multiple fields allows injection of un-sanitized HTML
- Lack of HTML escaping when rendering data on the front end

The attack vector here is limited, as only authenticated users are able to write data to the database, for it to be subsequently rendered on the front-end. However, it is a vulnerability that the InvenTree development team takes seriously.

### Solution

The proposed patch for this vulnerability is prevents injection of un-escaped fields into front-end UI elements.

A future patch will also address sanitization of database fields on the "back end", however this will require a much larger effort to refactor multiple database tables.

### Patches

- The issue is addressed in the upcoming `0.8.0` release
- This fix will also be back-ported to the `0.7.x` branch, applied to the `0.7.2` release

### Workarounds

There are no workarounds for this issue, users should upgrade to a patched version.

### References

- https://huntr.dev/bounties/4cae8442-c042-43c2-ad89-6f666eaf3d57/
- https://huntr.dev/bounties/9d640ef2-c52c-4106-b043-f7497d577078/
- https://huntr.dev/bounties/b114e82f-6c02-485b-82ea-e242f89169c2/
- https://huntr.dev/bounties/22783cd3-1b2c-48fc-b31f-03b53c86da0b/

Thank you @saharshtapi for bringing this issue to our attention and giving pointers for fixing them.

### For more information

If you have any questions or comments about this advisory:

* Open an issue in [github](http://github.com/inventree/inventree)
* Email us at [security@inventree.org](mailto:security@inventree.org)

## Which versions are affected by GHSA-rm89-9g65-4ffr?

2 open source packages ship an affected version, including inventree.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `inventree` | PyPI | All versions | 0.7.2 |
| `inventree` | PyPI | All versions | 0.7.2 |

## How do I fix GHSA-rm89-9g65-4ffr?

Upgrade inventree to 0.7.2 or later.

## Is GHSA-rm89-9g65-4ffr being exploited?

There is no known exploitation of GHSA-rm89-9g65-4ffr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-rm89-9g65-4ffr and fix it if it is affected.

What it is: GHSA-rm89-9g65-4ffr is a cross-site scripting vulnerability in inventree, published on 17 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-rm89-9g65-4ffr in the wild and no public exploit code.

Affected packages and fixed versions:
- inventree (PyPI): affected all versions; fixed in 0.7.2
- inventree (PyPI): affected all versions; fixed in 0.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-rm89-9g65-4ffr/ (Markdown: https://insights.sbomify.com/GHSA-rm89-9g65-4ffr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-rm89-9g65-4ffr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-rm89-9g65-4ffr/
Summaries are generated and may contain mistakes; the official description above is the record.
