{"answers":{"affected":"3 open source packages ship an affected version, including github.com/k8sgpt-ai/k8sgpt.","exploited":"There is no known exploitation of GHSA-rp7v-4384-hfrp in the wild and no public exploit code.","fix":"Upgrade github.com/k8sgpt-ai/k8sgpt to 0.4.32 or later.","what":"GHSA-rp7v-4384-hfrp is an unsafe deserialization vulnerability in github.com/k8sgpt-ai/k8sgpt, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rp7v-4384-hfrp and fix it if it is affected.\n\nWhat it is: GHSA-rp7v-4384-hfrp is an unsafe deserialization vulnerability in github.com/k8sgpt-ai/k8sgpt, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rp7v-4384-hfrp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/k8sgpt-ai/k8sgpt (Go): affected all versions; fixed in 0.4.32\n- github.com/k8sgpt-ai/k8sgpt (Go): affected all versions; fixed in 0.4.32\n- github.com/k8sgpt-ai/k8sgpt (Go): affected all versions; fixed in 0.4.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rp7v-4384-hfrp/ (Markdown: https://insights.sbomify.com/GHSA-rp7v-4384-hfrp/index.md)","id":"GHSA-rp7v-4384-hfrp","markdown":"https://insights.sbomify.com/GHSA-rp7v-4384-hfrp/index.md","name":"GHSA-rp7v-4384-hfrp","record":{"aliases":["GO-2026-5631"],"analysis":{"component_type":"cloud_service","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes AI tool","requires_auth":"none","summary":"Attackers can exploit prompt injection in k8sGPT to execute arbitrary code or escalate privileges via unsafe deserialization of AI-generated YAML.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nIn the auto-remediation pipeline, `object_to_execution.go` was deserializing the AI-generated YAML directly into a Deployment object, but there was lack of validation from the original Deployment object.\n\n### Details\nThis issue was fixed after coordination with Alex Jones.\n\n### PoC\nTo minimize the impact, the PoC of this vulnerability wasn't released, but was shared with the maintainers.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"k8sGPT has Prompt Injection through its k8sGPT-Operator","id":"GHSA-rp7v-4384-hfrp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.4.32"],"introduced":["0"],"last_affected":[],"package":"github.com/k8sgpt-ai/k8sgpt","purl":null,"source":"GHSA-rp7v-4384-hfrp"},{"ecosystem":"Go","fixed":["0.4.32"],"introduced":["0"],"last_affected":[],"package":"github.com/k8sgpt-ai/k8sgpt","purl":"pkg:golang/github.com/k8sgpt-ai/k8sgpt","source":"GHSA-rp7v-4384-hfrp"},{"ecosystem":"Go","fixed":["0.4.32"],"introduced":["0"],"last_affected":[],"package":"github.com/k8sgpt-ai/k8sgpt","purl":"pkg:golang/github.com/k8sgpt-ai/k8sgpt","source":"GO-2026-5631"}],"products":null,"published":"2026-04-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit prompt injection in k8sGPT to execute arbitrary code or escalate privileges via unsafe deserialization of AI-generated YAML.","url":"https://insights.sbomify.com/GHSA-rp7v-4384-hfrp/"}