{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security.","exploited":"There is no known exploitation of GHSA-rrmm-wq7q-h4v5 in the wild and no public exploit code.","fix":"Upgrade org.opensearch.plugin:opensearch-security to 2.19.3.0 or later.","what":"GHSA-rrmm-wq7q-h4v5 is a vulnerability in org.opensearch.plugin:opensearch-security, published on 1 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rrmm-wq7q-h4v5 and fix it if it is affected.\n\nWhat it is: GHSA-rrmm-wq7q-h4v5 is a vulnerability in org.opensearch.plugin:opensearch-security, published on 1 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rrmm-wq7q-h4v5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.plugin:opensearch-security (Maven): affected all versions; fixed in 2.19.3.0\n- org.opensearch.plugin:opensearch-security (Maven): affected all versions; fixed in 2.19.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rrmm-wq7q-h4v5/ (Markdown: https://insights.sbomify.com/GHSA-rrmm-wq7q-h4v5/index.md)","id":"GHSA-rrmm-wq7q-h4v5","markdown":"https://insights.sbomify.com/GHSA-rrmm-wq7q-h4v5/index.md","name":"GHSA-rrmm-wq7q-h4v5","record":{"aliases":[],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenSearch search engine","requires_auth":"low_privilege","summary":"Attackers can bypass field masking to read original values of specific geospatial and IP fields in OpenSearch, exposing sensitive data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nOpenSearch versions 2.19.2 and earlier improperly apply field masking rules on fields of the types `ip`, `geo_point`, `geo_shape`, `xy_point`, `xy_shape`. While the content of these fields is properly redacted in the `_source` document returned by search operations, the original unredacted values remain available to search queries. This allows to reconstruct the original field contents using range queries.\n\nAdditionally, the content of fields of type `geo_point`, `geo_shape`, `xy_point`, `xy_shape` is returned in an unredacted form if requested via the `fields` option of the search API.\n\n### Patches\n\nThe issue has been resolved in OpenSearch 3.0.0 and OpenSearch 2.19.3.\n\n### Workarounds\n\nIf you cannot upgrade immediately, you can avoid the problem by using field level security (FLS) protection on fields of the affected types instead of field masking.","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Impact OpenSearch versions 2.19.2 and earlier improperly apply field masking rules on fields of the types `ip`, `geo_point`, `geo_shape`","id":"GHSA-rrmm-wq7q-h4v5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.19.3.0"],"introduced":["0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":null,"source":"GHSA-rrmm-wq7q-h4v5"},{"ecosystem":"Maven","fixed":["2.19.3.0"],"introduced":["0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","source":"GHSA-rrmm-wq7q-h4v5"}],"products":null,"published":"2025-08-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass field masking to read original values of specific geospatial and IP fields in OpenSearch, exposing sensitive data.","url":"https://insights.sbomify.com/GHSA-rrmm-wq7q-h4v5/"}