{"answers":{"affected":"2 open source packages ship an affected version, including servey.","exploited":"There is no known exploitation of GHSA-rv49-54qp-fw42 in the wild and no public exploit code.","fix":"Upgrade servey to 3.1.0 or later.","what":"GHSA-rv49-54qp-fw42 is a path traversal vulnerability in servey, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rv49-54qp-fw42 and fix it if it is affected.\n\nWhat it is: GHSA-rv49-54qp-fw42 is a path traversal vulnerability in servey, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rv49-54qp-fw42 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- servey (npm): affected all versions; fixed in 3.1.0\n- servey (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rv49-54qp-fw42/ (Markdown: https://insights.sbomify.com/GHSA-rv49-54qp-fw42/index.md)","id":"GHSA-rv49-54qp-fw42","markdown":"https://insights.sbomify.com/GHSA-rv49-54qp-fw42/index.md","name":"GHSA-rv49-54qp-fw42","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js survey library","requires_auth":"none","summary":"Attackers can access server files via relative paths due to insufficient input sanitization in the servey library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `servey` prior to 3.x are vulnerable to Path Traversal.  Due to insufficient input sanitization, attackers can access server files by using relative paths. \n\n## Recommendation\n\nUpgrade to the latest version","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Path Traversal in servey","id":"GHSA-rv49-54qp-fw42","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"servey","purl":null,"source":"GHSA-rv49-54qp-fw42"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"servey","purl":"pkg:npm/servey","source":"GHSA-rv49-54qp-fw42"}],"products":null,"published":"2019-06-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can access server files via relative paths due to insufficient input sanitization in the servey library.","url":"https://insights.sbomify.com/GHSA-rv49-54qp-fw42/"}