{"answers":{"affected":"7 open source packages ship an affected version, including github.com/traefik/traefik/v2, github.com/traefik/traefik and github.com/traefik/traefik/v3.","exploited":"There is no known exploitation of GHSA-rvj4-q8q5-8grf in the wild and no public exploit code.","fix":"Upgrade github.com/traefik/traefik/v2 to 2.11.5 or later.","what":"GHSA-rvj4-q8q5-8grf is a vulnerability in github.com/traefik/traefik, published on 20 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-rvj4-q8q5-8grf and fix it if it is affected.\n\nWhat it is: GHSA-rvj4-q8q5-8grf is a vulnerability in github.com/traefik/traefik, published on 20 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-rvj4-q8q5-8grf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.5\n- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.5\n- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.5\n- github.com/traefik/traefik (Go): affected all versions; no fix listed\n- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.0.3\n- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.0.3\n- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-rvj4-q8q5-8grf/ (Markdown: https://insights.sbomify.com/GHSA-rvj4-q8q5-8grf/index.md)","id":"GHSA-rvj4-q8q5-8grf","markdown":"https://insights.sbomify.com/GHSA-rvj4-q8q5-8grf/index.md","name":"GHSA-rvj4-q8q5-8grf","record":{"aliases":["GO-2024-2941"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Traefik reverse proxy","requires_auth":"low_privilege","summary":"Traefik users must upgrade to prevent privilege escalation via vulnerable Azure Identity libraries.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThere is a vulnerability in [Azure Identity Libraries and Microsoft Authentication Library Elevation of Privilege Vulnerability](https://nvd.nist.gov/vuln/detail/CVE-2024-35255).\n\n### References\n\n- [CVE-2024-35255](https://nvd.nist.gov/vuln/detail/CVE-2024-35255)\n\n### Patches\n\n- https://github.com/traefik/traefik/releases/tag/v2.11.5\n- https://github.com/traefik/traefik/releases/tag/v3.0.3\n\n### Workarounds\n\nNo workaround.\n\n### For more information\n\nIf you have any questions or comments about this advisory, please [open an issue](https://github.com/traefik/traefik/issues).","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ACME DNS: Azure Identity Libraries Elevation of Privilege Vulnerability","id":"GHSA-rvj4-q8q5-8grf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":7,"n_references":null,"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik","purl":"pkg:golang/github.com/traefik/traefik","source":"GO-2024-2941"},{"ecosystem":"Go","fixed":["2.11.5"],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik/v2","purl":null,"source":"GHSA-rvj4-q8q5-8grf"},{"ecosystem":"Go","fixed":["2.11.5"],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik/v2","purl":"pkg:golang/github.com/traefik/traefik/v2","source":"GHSA-rvj4-q8q5-8grf"},{"ecosystem":"Go","fixed":["2.11.5"],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik/v2","purl":"pkg:golang/github.com/traefik/traefik/v2","source":"GO-2024-2941"},{"ecosystem":"Go","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik/v3","purl":null,"source":"GHSA-rvj4-q8q5-8grf"},{"ecosystem":"Go","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik/v3","purl":"pkg:golang/github.com/traefik/traefik/v3","source":"GHSA-rvj4-q8q5-8grf"},{"ecosystem":"Go","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"github.com/traefik/traefik/v3","purl":"pkg:golang/github.com/traefik/traefik/v3","source":"GO-2024-2941"}],"products":null,"published":"2024-06-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Traefik users must upgrade to prevent privilege escalation via vulnerable Azure Identity libraries.","url":"https://insights.sbomify.com/GHSA-rvj4-q8q5-8grf/"}