# GHSA-rwr8-xrpw-9qf5: solspace/craft-freeform Exposed to Known Axios Vulnerabilities via Precompiled Assets

> The plugin bundles vulnerable Axios versions, potentially allowing attackers to exploit known flaws in the underlying library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026

## What is GHSA-rwr8-xrpw-9qf5?

GHSA-rwr8-xrpw-9qf5 is a vulnerability in solspace/craft-freeform, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
The latest versions of both 4.x and 5.x are using Axios versions < 1.7.5 and as such are subject to known vulnerabilities as per: https://security.snyk.io/package/npm/axios

### Details
We've had this flagged up in a pen test, which indicates the issue stems from this script: /freeform/plugin.js. I couldn't see any reference to vulnerable axios versions in your package.json files, but noticed some precompiled files in packages/plugin so I'm assuming those are where the issue lies.

## Which versions are affected by GHSA-rwr8-xrpw-9qf5?

4 open source packages ship an affected version, including solspace/craft-freeform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `solspace/craft-freeform` | Packagist | All versions | 4.1.22 |
| `solspace/craft-freeform` | Packagist | All versions | 4.1.22 |
| `solspace/craft-freeform` | Packagist | From 5.0.0-beta.1 | 5.5.9 |
| `solspace/craft-freeform` | Packagist | From 5.0.0-beta.1 | 5.5.9 |

## How do I fix GHSA-rwr8-xrpw-9qf5?

Upgrade solspace/craft-freeform to a fixed version for your release line: 4.1.22 or 5.5.9.

## Is GHSA-rwr8-xrpw-9qf5 being exploited?

There is no known exploitation of GHSA-rwr8-xrpw-9qf5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-rwr8-xrpw-9qf5 and fix it if it is affected.

What it is: GHSA-rwr8-xrpw-9qf5 is a vulnerability in solspace/craft-freeform, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-rwr8-xrpw-9qf5 in the wild and no public exploit code.

Affected packages and fixed versions:
- solspace/craft-freeform (Packagist): affected all versions; fixed in 4.1.22
- solspace/craft-freeform (Packagist): affected all versions; fixed in 4.1.22
- solspace/craft-freeform (Packagist): affected from 5.0.0-beta.1; fixed in 5.5.9
- solspace/craft-freeform (Packagist): affected from 5.0.0-beta.1; fixed in 5.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-rwr8-xrpw-9qf5/ (Markdown: https://insights.sbomify.com/GHSA-rwr8-xrpw-9qf5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-rwr8-xrpw-9qf5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-rwr8-xrpw-9qf5/
Summaries are generated and may contain mistakes; the official description above is the record.
