{"answers":{"affected":"2 open source packages ship an affected version, including underscore.string.","exploited":"There is no known exploitation of GHSA-v2p6-4mp7-3r9v in the wild and no public exploit code.","fix":"Upgrade underscore.string to 3.3.5 or later.","what":"GHSA-v2p6-4mp7-3r9v is a denial of service vulnerability in underscore.string, published on 14 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-v2p6-4mp7-3r9v and fix it if it is affected.\n\nWhat it is: GHSA-v2p6-4mp7-3r9v is a denial of service vulnerability in underscore.string, published on 14 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-v2p6-4mp7-3r9v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- underscore.string (npm): affected all versions; fixed in 3.3.5\n- underscore.string (npm): affected all versions; fixed in 3.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v2p6-4mp7-3r9v/ (Markdown: https://insights.sbomify.com/GHSA-v2p6-4mp7-3r9v/index.md)","id":"GHSA-v2p6-4mp7-3r9v","markdown":"https://insights.sbomify.com/GHSA-v2p6-4mp7-3r9v/index.md","name":"GHSA-v2p6-4mp7-3r9v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript string library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using underscore.string by submitting specially crafted input to the unescapeHTML function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `underscore.string` prior to *3.3.5* are vulnerable to Regular Expression Denial of Service (ReDoS).\n\nThe function `unescapeHTML` is vulnerable to ReDoS due to an overly-broad regex. The slowdown is approximately 2s for 50,000 characters but grows exponentially with larger inputs.\n\n## Recommendation\n\nUpgrade to version 3.3.5 or higher.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Regular Expression Denial of Service in underscore.string","id":"GHSA-v2p6-4mp7-3r9v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.3.5"],"introduced":["0"],"last_affected":[],"package":"underscore.string","purl":null,"source":"GHSA-v2p6-4mp7-3r9v"},{"ecosystem":"npm","fixed":["3.3.5"],"introduced":["0"],"last_affected":[],"package":"underscore.string","purl":"pkg:npm/underscore.string","source":"GHSA-v2p6-4mp7-3r9v"}],"products":null,"published":"2019-06-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service in applications using underscore.string by submitting specially crafted input to the unescapeHTML function.","url":"https://insights.sbomify.com/GHSA-v2p6-4mp7-3r9v/"}