{"answers":{"affected":"2 open source packages ship an affected version, including terminal42/contao-tablelookupwizard.","exploited":"There is no known exploitation of GHSA-v3mr-gp7j-pw5w in the wild and no public exploit code.","fix":"Upgrade terminal42/contao-tablelookupwizard to 3.3.5 or later.","what":"GHSA-v3mr-gp7j-pw5w is a SQL injection vulnerability in terminal42/contao-tablelookupwizard, published on 10 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-v3mr-gp7j-pw5w and fix it if it is affected.\n\nWhat it is: GHSA-v3mr-gp7j-pw5w is a SQL injection vulnerability in terminal42/contao-tablelookupwizard, published on 10 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-v3mr-gp7j-pw5w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- terminal42/contao-tablelookupwizard (Packagist): affected all versions; fixed in 3.3.5\n- terminal42/contao-tablelookupwizard (Packagist): affected all versions; fixed in 3.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v3mr-gp7j-pw5w/ (Markdown: https://insights.sbomify.com/GHSA-v3mr-gp7j-pw5w/index.md)","id":"GHSA-v3mr-gp7j-pw5w","markdown":"https://insights.sbomify.com/GHSA-v3mr-gp7j-pw5w/index.md","name":"GHSA-v3mr-gp7j-pw5w","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Contao extension","requires_auth":"low_privilege","summary":"An SQL injection vulnerability in the Contao tablelookupwizard extension allows attackers to manipulate database queries via unsanitized widget values.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThe currently selected widget values were not correctly sanitized before passing it to the database, leading to an SQL injection possibility.\n\n### Patches\nThe issue has been patched in `tablelookupwizard` version 3.3.5 and version 4.0.0.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in https://github.com/terminal42/contao-tablelookupwizard\n* Email us at [info@terminal42.ch](mailto:info@terminal42.ch)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Possible SQL injection in tablelookupwizard Contao Extension","id":"GHSA-v3mr-gp7j-pw5w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.3.5"],"introduced":["0"],"last_affected":[],"package":"terminal42/contao-tablelookupwizard","purl":null,"source":"GHSA-v3mr-gp7j-pw5w"},{"ecosystem":"Packagist","fixed":["3.3.5"],"introduced":["0"],"last_affected":[],"package":"terminal42/contao-tablelookupwizard","purl":"pkg:composer/terminal42/contao-tablelookupwizard","source":"GHSA-v3mr-gp7j-pw5w"}],"products":null,"published":"2022-02-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An SQL injection vulnerability in the Contao tablelookupwizard extension allows attackers to manipulate database queries via unsanitized widget values.","url":"https://insights.sbomify.com/GHSA-v3mr-gp7j-pw5w/"}