{"answers":{"affected":"2 open source packages ship an affected version, including bin-links.","exploited":"There is no known exploitation of GHSA-v45m-2wcp-gg98 in the wild and no public exploit code.","fix":"Upgrade bin-links to 1.1.6 or later.","what":"GHSA-v45m-2wcp-gg98 is a vulnerability in bin-links, published on 4 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-v45m-2wcp-gg98 and fix it if it is affected.\n\nWhat it is: GHSA-v45m-2wcp-gg98 is a vulnerability in bin-links, published on 4 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-v45m-2wcp-gg98 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bin-links (npm): affected all versions; fixed in 1.1.6\n- bin-links (npm): affected all versions; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v45m-2wcp-gg98/ (Markdown: https://insights.sbomify.com/GHSA-v45m-2wcp-gg98/index.md)","id":"GHSA-v45m-2wcp-gg98","markdown":"https://insights.sbomify.com/GHSA-v45m-2wcp-gg98/index.md","name":"GHSA-v45m-2wcp-gg98","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"npm package manager","requires_auth":"none","summary":"Attackers can overwrite globally installed binaries by installing packages with conflicting names, potentially leading to malicious code execution.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of  `bin-links` prior to 1.1.6 are vulnerable to a Global node_modules Binary Overwrite. It fails to prevent globally-installed binaries to be overwritten by other package installs. For example, if a package was installed globally and created a `serve` binary, any subsequent installs of packages that also create a `serve` binary would overwrite the first binary. This behavior is still allowed in local installations.\n\n## Recommendation\n\nUpgrade to version 1.1.6 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Global node_modules Binary Overwrite in bin-links","id":"GHSA-v45m-2wcp-gg98","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"bin-links","purl":null,"source":"GHSA-v45m-2wcp-gg98"},{"ecosystem":"npm","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"bin-links","purl":"pkg:npm/bin-links","source":"GHSA-v45m-2wcp-gg98"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can overwrite globally installed binaries by installing packages with conflicting names, potentially leading to malicious code execution.","url":"https://insights.sbomify.com/GHSA-v45m-2wcp-gg98/"}