{"answers":{"affected":"2 open source packages ship an affected version, including express-laravel-passport.","exploited":"There is no known exploitation of GHSA-v66p-w7qx-wv98 in the wild and no public exploit code.","fix":"No fix has been published for GHSA-v66p-w7qx-wv98 yet. Limit exposure of the affected software until one is available.","what":"GHSA-v66p-w7qx-wv98 is an authentication bypass vulnerability in express-laravel-passport, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-v66p-w7qx-wv98 and fix it if it is affected.\n\nWhat it is: GHSA-v66p-w7qx-wv98 is an authentication bypass vulnerability in express-laravel-passport, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-v66p-w7qx-wv98 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-laravel-passport (npm): affected from 0.0.0; no fix listed\n- express-laravel-passport (npm): affected from 0.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v66p-w7qx-wv98/ (Markdown: https://insights.sbomify.com/GHSA-v66p-w7qx-wv98/index.md)","id":"GHSA-v66p-w7qx-wv98","markdown":"https://insights.sbomify.com/GHSA-v66p-w7qx-wv98/index.md","name":"GHSA-v66p-w7qx-wv98","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js authentication library","requires_auth":"none","summary":"Attackers can bypass authentication and impersonate users due to improper JWT validation in the express-laravel-passport library.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"All versions of `express-laravel-passport` are vulnerable to an Authentication Bypass. The package fails to properly validate JWTs, allowing attackers to send HTTP requests impersonating other users.\n\n## Recommendation\n\nUpgrade to version 2.0.5 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"Authentication Bypass in express-laravel-passport","id":"GHSA-v66p-w7qx-wv98","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0.0.0"],"last_affected":[],"package":"express-laravel-passport","purl":null,"source":"GHSA-v66p-w7qx-wv98"},{"ecosystem":"npm","fixed":[],"introduced":["0.0.0"],"last_affected":[],"package":"express-laravel-passport","purl":"pkg:npm/express-laravel-passport","source":"GHSA-v66p-w7qx-wv98"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass authentication and impersonate users due to improper JWT validation in the express-laravel-passport library.","url":"https://insights.sbomify.com/GHSA-v66p-w7qx-wv98/"}