{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri.","exploited":"There is no known exploitation of GHSA-v6gp-9mmm-c6p5 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.13.4 or later.","what":"GHSA-v6gp-9mmm-c6p5 is a memory corruption vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-v6gp-9mmm-c6p5 and fix it if it is affected.\n\nWhat it is: GHSA-v6gp-9mmm-c6p5 is a memory corruption vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-v6gp-9mmm-c6p5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.4\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/ (Markdown: https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/index.md)","id":"GHSA-v6gp-9mmm-c6p5","markdown":"https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/index.md","name":"GHSA-v6gp-9mmm-c6p5","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML library","requires_auth":"none","summary":"An out-of-bounds write in the vendored zlib library within Nokogiri allows attackers to cause memory corruption, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\n\nNokogiri v1.13.4 updates the vendored zlib from 1.2.11 to 1.2.12, which addresses [CVE-2018-25032](https://nvd.nist.gov/vuln/detail/CVE-2018-25032). That CVE is scored as CVSS 7.4 \"High\" on the NVD record as of 2022-04-05.\n\nPlease note that this advisory only applies to the CRuby implementation of Nokogiri `\u003c 1.13.4`, and only if the packaged version of `zlib` is being used. Please see [this document](https://nokogiri.org/LICENSE-DEPENDENCIES.html#default-platform-release-ruby) for a complete description of which platform gems vendor `zlib`. If you've overridden defaults at installation time to use system libraries instead of packaged libraries, you should instead pay attention to your distro's `zlib` release announcements. \n\n## Mitigation\n\nUpgrade to Nokogiri `\u003e= v1.13.4`.\n\n## Impact\n\n### [CVE-2018-25032](https://nvd.nist.gov/vuln/detail/CVE-2018-25032) in zlib\n\n- **Severity**: High\n- **Type**: [CWE-787](https://cwe.mitre.org/data/definitions/787.html) Out of bounds write\n- **Description**: zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches.","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Out-of-bounds Write in zlib affects Nokogiri","id":"GHSA-v6gp-9mmm-c6p5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["1.13.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-v6gp-9mmm-c6p5"},{"ecosystem":"RubyGems","fixed":["1.13.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-v6gp-9mmm-c6p5"}],"products":null,"published":"2022-04-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An out-of-bounds write in the vendored zlib library within Nokogiri allows attackers to cause memory corruption, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/"}