# GHSA-v6gp-9mmm-c6p5: Out-of-bounds Write in zlib affects Nokogiri

> An out-of-bounds write in the vendored zlib library within Nokogiri allows attackers to cause memory corruption, potentially leading to code execution or denial of service.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022

## What is GHSA-v6gp-9mmm-c6p5?

GHSA-v6gp-9mmm-c6p5 is a memory corruption vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Summary

Nokogiri v1.13.4 updates the vendored zlib from 1.2.11 to 1.2.12, which addresses [CVE-2018-25032](https://nvd.nist.gov/vuln/detail/CVE-2018-25032). That CVE is scored as CVSS 7.4 "High" on the NVD record as of 2022-04-05.

Please note that this advisory only applies to the CRuby implementation of Nokogiri `< 1.13.4`, and only if the packaged version of `zlib` is being used. Please see [this document](https://nokogiri.org/LICENSE-DEPENDENCIES.html#default-platform-release-ruby) for a complete description of which platform gems vendor `zlib`. If you've overridden defaults at installation time to use system libraries instead of packaged libraries, you should instead pay attention to your distro's `zlib` release announcements. 

## Mitigation

Upgrade to Nokogiri `>= v1.13.4`.

## Impact

### [CVE-2018-25032](https://nvd.nist.gov/vuln/detail/CVE-2018-25032) in zlib

- **Severity**: High
- **Type**: [CWE-787](https://cwe.mitre.org/data/definitions/787.html) Out of bounds write
- **Description**: zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches.

## Which versions are affected by GHSA-v6gp-9mmm-c6p5?

2 open source packages ship an affected version, including nokogiri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.13.4 |
| `nokogiri` | RubyGems | All versions | 1.13.4 |

## How do I fix GHSA-v6gp-9mmm-c6p5?

Upgrade nokogiri to 1.13.4 or later.

## Is GHSA-v6gp-9mmm-c6p5 being exploited?

There is no known exploitation of GHSA-v6gp-9mmm-c6p5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-v6gp-9mmm-c6p5 and fix it if it is affected.

What it is: GHSA-v6gp-9mmm-c6p5 is a memory corruption vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-v6gp-9mmm-c6p5 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/ (Markdown: https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-v6gp-9mmm-c6p5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-v6gp-9mmm-c6p5/
Summaries are generated and may contain mistakes; the official description above is the record.
