{"answers":{"affected":"4 open source packages ship an affected version, including october/october and october/system.","exploited":"There is no known exploitation of GHSA-v73w-r9xg-7cr9 in the wild and no public exploit code.","fix":"Upgrade october/october to 1.0.466 or later.","what":"GHSA-v73w-r9xg-7cr9 is a cross-site scripting vulnerability in october/october, published on 5 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-v73w-r9xg-7cr9 and fix it if it is affected.\n\nWhat it is: GHSA-v73w-r9xg-7cr9 is a cross-site scripting vulnerability in october/october, published on 5 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-v73w-r9xg-7cr9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- october/october (Packagist): affected from 1.0.319; fixed in 1.0.466\n- october/october (Packagist): affected from 1.0.319; fixed in 1.0.466\n- october/system (Packagist): affected from 1.0.319; fixed in 1.0.466\n- october/system (Packagist): affected from 1.0.319; fixed in 1.0.466\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v73w-r9xg-7cr9/ (Markdown: https://insights.sbomify.com/GHSA-v73w-r9xg-7cr9/index.md)","id":"GHSA-v73w-r9xg-7cr9","markdown":"https://insights.sbomify.com/GHSA-v73w-r9xg-7cr9/index.md","name":"GHSA-v73w-r9xg-7cr9","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OctoberCMS","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victim browsers via insecure jQuery DOM manipulation methods in OctoberCMS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nPassing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code.\n\n### Patches\nIssue has been patched in Build 466 (v1.0.466) by applying the recommended patch from @jquery.\n\n### Workarounds\nApply https://github.com/octobercms/october/commit/5c7ba9fbe9f2b596b2f0e3436ee06b91b97e5892 to your installation manually if unable to upgrade to Build 466.\n\n### References\n- https://github.com/jquery/jquery/security/advisories/GHSA-gxr4-xjj5-5px2\n- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11022\n- https://jquery.com/upgrade-guide/3.5/\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Email us at [octobercms@luketowers.ca](mailto:octobercms@luketowers.ca) \u0026 [hello@octobercms.com](mailto:hello@octobercms.com)\n\n### Threat Assessment\nAssessed as Moderate by the @jquery team.\n\n### Acknowledgements\n\nThanks to @mrgswift for reporting the issue to the October CMS team.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Use of insecure jQuery version in OctoberCMS","id":"GHSA-v73w-r9xg-7cr9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.0.466"],"introduced":["1.0.319"],"last_affected":[],"package":"october/october","purl":null,"source":"GHSA-v73w-r9xg-7cr9"},{"ecosystem":"Packagist","fixed":["1.0.466"],"introduced":["1.0.319"],"last_affected":[],"package":"october/october","purl":"pkg:composer/october/october","source":"GHSA-v73w-r9xg-7cr9"},{"ecosystem":"Packagist","fixed":["1.0.466"],"introduced":["1.0.319"],"last_affected":[],"package":"october/system","purl":null,"source":"GHSA-v73w-r9xg-7cr9"},{"ecosystem":"Packagist","fixed":["1.0.466"],"introduced":["1.0.319"],"last_affected":[],"package":"october/system","purl":"pkg:composer/october/system","source":"GHSA-v73w-r9xg-7cr9"}],"products":null,"published":"2020-06-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in victim browsers via insecure jQuery DOM manipulation methods in OctoberCMS.","url":"https://insights.sbomify.com/GHSA-v73w-r9xg-7cr9/"}