# GHSA-v7hc-87jc-qrrr: Impact The eventing-github cluster-local server doesn't set `ReadHeaderTimeout`‬‭ which could lead do a DDoS‬ ‭attack, where a large gro

> Attackers can cause a denial of service via Slowloris attacks due to missing read header timeouts in the Knative eventing-github server.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2023
- **Also known as:** GO-2023-2388

## What is GHSA-v7hc-87jc-qrrr?

GHSA-v7hc-87jc-qrrr is a denial of service vulnerability in knative.dev/eventing-github, published on 6 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

The eventing-github cluster-local server doesn't set `ReadHeaderTimeout`‬‭ which could lead do a DDoS‬ ‭attack, where a large group of users send requests to the server causing the server to hang‬ ‭for long enough to deny it from being available to other users, also know as a Slowloris‬ ‭attack.

### Patches

Fix in `v1.12.1` and `v1.11.3`

### Credits

The vulnerability was reported by Ada Logics during an ongoing security audit of Knative involving Ada Logics, the Knative maintainers, OSTIF and CNCF.

## Which versions are affected by GHSA-v7hc-87jc-qrrr?

3 open source packages ship an affected version, including knative.dev/eventing-github.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knative.dev/eventing-github` | Go | All versions | 0.39.1 |
| `knative.dev/eventing-github` | Go | All versions | 0.39.1 |
| `knative.dev/eventing-github` | Go | All versions | 0.39.1 |

## How do I fix GHSA-v7hc-87jc-qrrr?

Upgrade knative.dev/eventing-github to 0.39.1 or later.

## Is GHSA-v7hc-87jc-qrrr being exploited?

There is no known exploitation of GHSA-v7hc-87jc-qrrr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-v7hc-87jc-qrrr and fix it if it is affected.

What it is: GHSA-v7hc-87jc-qrrr is a denial of service vulnerability in knative.dev/eventing-github, published on 6 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-v7hc-87jc-qrrr in the wild and no public exploit code.

Affected packages and fixed versions:
- knative.dev/eventing-github (Go): affected all versions; fixed in 0.39.1
- knative.dev/eventing-github (Go): affected all versions; fixed in 0.39.1
- knative.dev/eventing-github (Go): affected all versions; fixed in 0.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-v7hc-87jc-qrrr/ (Markdown: https://insights.sbomify.com/GHSA-v7hc-87jc-qrrr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-v7hc-87jc-qrrr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-v7hc-87jc-qrrr/
Summaries are generated and may contain mistakes; the official description above is the record.
