GHSA-v8gr-m533-ghj9 Vulnerable OpenSSL included in cryptography wheels

Not scored Published

Attackers can exploit vulnerabilities in the bundled OpenSSL library within the Python cryptography package to execute code or read data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-v8gr-m533-ghj9?

GHSA-v8gr-m533-ghj9 is a vulnerability in cryptography, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 2.5-41.0.3 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230908.txt.

If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Which versions are affected by GHSA-v8gr-m533-ghj9?

2 open source packages ship an affected version, including cryptography.

PackageAffectedFixed in
cryptography PyPIFrom 2.541.0.4
cryptography PyPIFrom 2.541.0.4

How do I fix GHSA-v8gr-m533-ghj9?

Upgrade cryptography to 41.0.4 or later.

Is GHSA-v8gr-m533-ghj9 being exploited?

There is no known exploitation of GHSA-v8gr-m533-ghj9 in the wild and no public exploit code.

Sources

Is GHSA-v8gr-m533-ghj9 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free