{"answers":{"affected":"2 open source packages ship an affected version, including cryptography.","exploited":"There is no known exploitation of GHSA-v8gr-m533-ghj9 in the wild and no public exploit code.","fix":"Upgrade cryptography to 41.0.4 or later.","what":"GHSA-v8gr-m533-ghj9 is a vulnerability in cryptography, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-v8gr-m533-ghj9 and fix it if it is affected.\n\nWhat it is: GHSA-v8gr-m533-ghj9 is a vulnerability in cryptography, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-v8gr-m533-ghj9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptography (PyPI): affected from 2.5; fixed in 41.0.4\n- cryptography (PyPI): affected from 2.5; fixed in 41.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v8gr-m533-ghj9/ (Markdown: https://insights.sbomify.com/GHSA-v8gr-m533-ghj9/index.md)","id":"GHSA-v8gr-m533-ghj9","markdown":"https://insights.sbomify.com/GHSA-v8gr-m533-ghj9/index.md","name":"GHSA-v8gr-m533-ghj9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"Attackers can exploit vulnerabilities in the bundled OpenSSL library within the Python cryptography package to execute code or read data.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 2.5-41.0.3 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230908.txt.\n\nIf you are building cryptography source (\"sdist\") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Vulnerable OpenSSL included in cryptography wheels","id":"GHSA-v8gr-m533-ghj9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["41.0.4"],"introduced":["2.5"],"last_affected":[],"package":"cryptography","purl":null,"source":"GHSA-v8gr-m533-ghj9"},{"ecosystem":"PyPI","fixed":["41.0.4"],"introduced":["2.5"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"GHSA-v8gr-m533-ghj9"}],"products":null,"published":"2023-09-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit vulnerabilities in the bundled OpenSSL library within the Python cryptography package to execute code or read data.","url":"https://insights.sbomify.com/GHSA-v8gr-m533-ghj9/"}