{"answers":{"affected":"2 open source packages ship an affected version, including jquery.json-viewer.","exploited":"There is no known exploitation of GHSA-v9wp-8r97-v6xg in the wild and no public exploit code.","fix":"Upgrade jquery.json-viewer to 1.3.0 or later.","what":"GHSA-v9wp-8r97-v6xg is a cross-site scripting vulnerability in jquery.json-viewer, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-v9wp-8r97-v6xg and fix it if it is affected.\n\nWhat it is: GHSA-v9wp-8r97-v6xg is a cross-site scripting vulnerability in jquery.json-viewer, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-v9wp-8r97-v6xg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jquery.json-viewer (npm): affected all versions; fixed in 1.3.0\n- jquery.json-viewer (npm): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-v9wp-8r97-v6xg/ (Markdown: https://insights.sbomify.com/GHSA-v9wp-8r97-v6xg/index.md)","id":"GHSA-v9wp-8r97-v6xg","markdown":"https://insights.sbomify.com/GHSA-v9wp-8r97-v6xg/index.md","name":"GHSA-v9wp-8r97-v6xg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript JSON viewer","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via malicious JSON payloads due to insufficient input sanitization in jquery.json-viewer.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `jquery.json-viewer` prior to 1.3.0 are vulnerable to Cross-Site Scripting (XSS). The package insufficiently sanitizes user input when creating links, and concatenates the user input in an `\u003ca\u003e` tag. This allows attackers to create malicious links with JSON payloads such as: \n```\n{\n  \"foo\": \"https://bar.com\\\" onmouseover=alert('xss') \\\"\"\n}\n```\n\nThis may lead to arbitrary JavaScript execution in a victim's browser.\n\n## Recommendation\n\nUpgrade to version 1.3.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in jquery.json-viewer","id":"GHSA-v9wp-8r97-v6xg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"jquery.json-viewer","purl":null,"source":"GHSA-v9wp-8r97-v6xg"},{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"jquery.json-viewer","purl":"pkg:npm/jquery.json-viewer","source":"GHSA-v9wp-8r97-v6xg"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via malicious JSON payloads due to insufficient input sanitization in jquery.json-viewer.","url":"https://insights.sbomify.com/GHSA-v9wp-8r97-v6xg/"}