GHSA-vc29-vg52-6643 DoS Vulnerability in TraceContextPropagator.Extract - OpenTelemetry.Api
Remote attackers can cause denial of service via high CPU usage by sending crafted tracestate headers to applications using vulnerable OpenTelemetry .NET libraries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-vc29-vg52-6643?
GHSA-vc29-vg52-6643 is a denial of service vulnerability in OpenTelemetry.AutoInstrumentation, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
What kind of vulnerability is it? Who is impacted?
A vulnerability in OpenTelemetry.Api package 1.10.0 to 1.11.1 could cause a Denial of Service (DoS) when a tracestate and traceparent header is received. These versions are used in OpenTelemetry .NET Automatic Instrumentation 1.10.0-beta.1 and 1.10.0.
Even if an application does not explicitly use trace context propagation, receiving these headers can still trigger high CPU usage. This issue impacts any application accessible over the web or backend services that process HTTP requests containing a tracestate header. Application may experience excessive resource consumption, leading to increased latency, degraded performance, or downtime.
Patches
Has the problem been patched? What versions should users upgrade to?
This issue has been resolved in OpenTelemetry.Api 1.11.2 by reverting the change that introduced the problematic behavior in versions 1.10.0 to 1.11.1. OpenTelemetry .NET Automatic Instrumentation fixes it in 1.11.0 release.
Fixed version
| OpenTelemetry .NET Automatic Instrumentation | Status |
|---|---|
| <= 1.9.0 | ✅ Not affected |
| 1.10.0-beta.1, 1.10.0 | ❌ Vulnerable |
| 1.11.0 (Fixed) | ✅ Safe to use |
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
References
Are there any links users can visit to find out more?
Which versions are affected by GHSA-vc29-vg52-6643?
2 open source packages ship an affected version, including OpenTelemetry.AutoInstrumentation.
| Package | Affected | Fixed in |
|---|---|---|
OpenTelemetry.AutoInstrumentation NuGet | From 1.10.0-beta.1 | 1.11.0 |
OpenTelemetry.AutoInstrumentation NuGet | From 1.10.0-beta.1 | 1.11.0 |
How do I fix GHSA-vc29-vg52-6643?
Upgrade OpenTelemetry.AutoInstrumentation to 1.11.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-vc29-vg52-6643 being exploited?
There is no known exploitation of GHSA-vc29-vg52-6643 in the wild and no public exploit code.