# GHSA-vc29-vg52-6643: DoS Vulnerability in TraceContextPropagator.Extract - OpenTelemetry.Api

> Remote attackers can cause denial of service via high CPU usage by sending crafted tracestate headers to applications using vulnerable OpenTelemetry .NET libraries.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2025

## What is GHSA-vc29-vg52-6643?

GHSA-vc29-vg52-6643 is a denial of service vulnerability in OpenTelemetry.AutoInstrumentation, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
_What kind of vulnerability is it? Who is impacted?_

A vulnerability in `OpenTelemetry.Api` package `1.10.0` to `1.11.1` could cause a [Denial of Service (DoS) when a tracestate and traceparent header is received](https://github.com/open-telemetry/opentelemetry-dotnet/security/advisories/GHSA-8785-wc3w-h8q6). These versions are used in OpenTelemetry .NET Automatic Instrumentation `1.10.0-beta.1` and `1.10.0`.

Even if an application does not explicitly use trace context propagation, receiving these headers can still trigger high CPU usage.
This issue impacts any application accessible over the web or backend services that process HTTP requests containing a tracestate header.
Application may experience excessive resource consumption, leading to increased latency, degraded performance, or downtime.

### Patches
_Has the problem been patched? What versions should users upgrade to?_

This issue has been resolved in `OpenTelemetry.Api` `1.11.2` by reverting the change that introduced the problematic behavior in versions `1.10.0` to `1.11.1`. OpenTelemetry .NET Automatic Instrumentation fixes it in `1.11.0` release.

## Fixed version

| OpenTelemetry .NET Automatic Instrumentation | Status |
|----|----|
| <= 1.9.0 | ✅ Not affected |
| 1.10.0-beta.1, 1.10.0 | ❌ Vulnerable |
| 1.11.0 (Fixed)| ✅ Safe to use|

### Workarounds
_Is there a way for users to fix or remediate the vulnerability without upgrading?_

### References
_Are there any links users can visit to find out more?_

## Which versions are affected by GHSA-vc29-vg52-6643?

2 open source packages ship an affected version, including OpenTelemetry.AutoInstrumentation.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OpenTelemetry.AutoInstrumentation` | NuGet | From 1.10.0-beta.1 | 1.11.0 |
| `OpenTelemetry.AutoInstrumentation` | NuGet | From 1.10.0-beta.1 | 1.11.0 |

## How do I fix GHSA-vc29-vg52-6643?

Upgrade OpenTelemetry.AutoInstrumentation to 1.11.0 or later.

## Is GHSA-vc29-vg52-6643 being exploited?

There is no known exploitation of GHSA-vc29-vg52-6643 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vc29-vg52-6643 and fix it if it is affected.

What it is: GHSA-vc29-vg52-6643 is a denial of service vulnerability in OpenTelemetry.AutoInstrumentation, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-vc29-vg52-6643 in the wild and no public exploit code.

Affected packages and fixed versions:
- OpenTelemetry.AutoInstrumentation (NuGet): affected from 1.10.0-beta.1; fixed in 1.11.0
- OpenTelemetry.AutoInstrumentation (NuGet): affected from 1.10.0-beta.1; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vc29-vg52-6643/ (Markdown: https://insights.sbomify.com/GHSA-vc29-vg52-6643/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vc29-vg52-6643

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vc29-vg52-6643/
Summaries are generated and may contain mistakes; the official description above is the record.
