{"answers":{"affected":"2 open source packages ship an affected version, including m-server.","exploited":"There is no known exploitation of GHSA-vc6r-4x6g-mmqc in the wild and no public exploit code.","fix":"Upgrade m-server to 1.4.2 or later.","what":"GHSA-vc6r-4x6g-mmqc is a path traversal vulnerability in m-server, published on 11 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vc6r-4x6g-mmqc and fix it if it is affected.\n\nWhat it is: GHSA-vc6r-4x6g-mmqc is a path traversal vulnerability in m-server, published on 11 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vc6r-4x6g-mmqc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- m-server (npm): affected all versions; fixed in 1.4.2\n- m-server (npm): affected all versions; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vc6r-4x6g-mmqc/ (Markdown: https://insights.sbomify.com/GHSA-vc6r-4x6g-mmqc/index.md)","id":"GHSA-vc6r-4x6g-mmqc","markdown":"https://insights.sbomify.com/GHSA-vc6r-4x6g-mmqc/index.md","name":"GHSA-vc6r-4x6g-mmqc","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"m-server","requires_auth":"none","summary":"A remote attacker can exploit a path traversal vulnerability in m-server to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `m-server` before 1.4.2 are vulnerable to path traversal allowing a remote attacker to display content of arbitrary files from the server.\n\n## Recommendation\n\nUpdate to version 1.4.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Path Traversal in m-server","id":"GHSA-vc6r-4x6g-mmqc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"m-server","purl":null,"source":"GHSA-vc6r-4x6g-mmqc"},{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"m-server","purl":"pkg:npm/m-server","source":"GHSA-vc6r-4x6g-mmqc"}],"products":null,"published":"2019-06-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A remote attacker can exploit a path traversal vulnerability in m-server to read arbitrary files from the server.","url":"https://insights.sbomify.com/GHSA-vc6r-4x6g-mmqc/"}