{"answers":{"affected":"2 open source packages ship an affected version, including next.","exploited":"There is no known exploitation of GHSA-vcvr-r3jv-pc5j in the wild and no public exploit code.","fix":"Upgrade next to 16.3.6 or later.","what":"GHSA-vcvr-r3jv-pc5j is a code injection vulnerability in next, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vcvr-r3jv-pc5j and fix it if it is affected.\n\nWhat it is: GHSA-vcvr-r3jv-pc5j is a code injection vulnerability in next, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vcvr-r3jv-pc5j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 16.2.0; fixed in 16.3.6\n- next (npm): affected from 16.2.0; fixed in 16.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vcvr-r3jv-pc5j/ (Markdown: https://insights.sbomify.com/GHSA-vcvr-r3jv-pc5j/index.md)","id":"GHSA-vcvr-r3jv-pc5j","markdown":"https://insights.sbomify.com/GHSA-vcvr-r3jv-pc5j/index.md","name":"GHSA-vcvr-r3jv-pc5j","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Next.js framework","requires_auth":"none","summary":"Remote code execution in Next.js ImageResponse allows attackers to execute arbitrary code via crafted SVG inputs in Node.js environments.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nThe Node.js `ImageResponse` implementation from `next/og` is affected by an upstream vulnerability. This can lead to remote code execution.\n\nAffected applications pass attacker-controlled values into SVG content, attributes, or styles during image generation:\n\n```tsx\nimport { ImageResponse } from 'next/og'\n\nexport async function GET(request: Request) {\n  const value = new URL(request.url).searchParams.get('value') ?? ''\n\n  return new ImageResponse(\n    \u003csvg width=\"1200\" height=\"630\"\u003e\n      \u003ctitle\u003e{value}\u003c/title\u003e\n    \u003c/svg\u003e\n  )\n}\n```\n\nApplications using the Edge `ImageResponse` implementation, or applications that do not pass attacker-controlled values into SVG content, attributes, or styles, are not affected.\n\n## Workaround\n\nIf upgrading is not immediately possible, do not pass attacker-controlled values into SVG content, attributes, or styles rendered by the Node.js `ImageResponse` implementation from `next/og`.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Next.js: Remote Code Execution in next/og ImageResponse","id":"GHSA-vcvr-r3jv-pc5j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["16.3.6"],"introduced":["16.2.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-vcvr-r3jv-pc5j"},{"ecosystem":"npm","fixed":["16.3.6"],"introduced":["16.2.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-vcvr-r3jv-pc5j"}],"products":null,"published":"2026-09-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote code execution in Next.js ImageResponse allows attackers to execute arbitrary code via crafted SVG inputs in Node.js environments.","url":"https://insights.sbomify.com/GHSA-vcvr-r3jv-pc5j/"}