GHSA-vf5j-r2hw-2hrw OpenCloud Affected by Public Link Exploit
A malicious user can bypass public link scope validation in OpenCloud to access unauthorized resources outside the intended share scope.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-vf5j-r2hw-2hrw?
GHSA-vf5j-r2hw-2hrw is a missing authorization vulnerability in github.com/opencloud-eu/opencloud, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Impact
A security issue was discovered in Reva that enables a malicious user to bypass the scope validation of a public link. That allows it to access resources outside the scope of a public link.
OpenCloud uses Reva as one of its core components and thus it is affected.
Patches
Update to OpenCloud version >= 4.0.3 (stable release) Update to OpenCloud version >= 5.0.2 (rolling release)
Workarounds
If projects are unable to update immediately, please implement the following security configuration to disable public link shares temporarily until the final solution for this problem is rolled out.
Configuration Adjustment
- Docker Compose: Edit the docker-compose.yml and add
GATEWAY_STORAGE_PUBLIC_LINK_ENDPOINT=“”(empty string value) in theenvironmentsection of theopencloudcontainer.
Verification of Mitigation
Execute the following test:
- Create a public link for testing.
- Open the link url in a private (no active login) browser tab.
- An error page with “unknown error” will be displayed.
This configuration provides immediate protection and should be implemented immediately. Configuration mitigation is available. It mitigates the problem completely.
For more information
If there are questions or comments about this advisory:
- Security Support: [email protected]
- Technical Support: [email protected]
Which versions are affected by GHSA-vf5j-r2hw-2hrw?
5 open source packages ship an affected version, including github.com/opencloud-eu/opencloud.
| Package | Affected | Fixed in |
|---|---|---|
github.com/opencloud-eu/opencloud Go | All versions | None |
github.com/opencloud-eu/opencloud Go | From 4.0.0 | 4.0.3 |
github.com/opencloud-eu/opencloud Go | From 4.0.0 | 4.0.3 |
github.com/opencloud-eu/opencloud Go | From 5.0.0 | 5.0.2 |
github.com/opencloud-eu/opencloud Go | From 5.0.0 | 5.0.2 |
How do I fix GHSA-vf5j-r2hw-2hrw?
Upgrade github.com/opencloud-eu/opencloud to a fixed version for your release line: 4.0.3 or 5.0.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is GHSA-vf5j-r2hw-2hrw being exploited?
There is no known exploitation of GHSA-vf5j-r2hw-2hrw in the wild and no public exploit code.
Sources
Also known as GO-2026-4447.