# GHSA-vf5j-r2hw-2hrw: OpenCloud Affected by Public Link Exploit

> A malicious user can bypass public link scope validation in OpenCloud to access unauthorized resources outside the intended share scope.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2026
- **Also known as:** GO-2026-4447

## What is GHSA-vf5j-r2hw-2hrw?

GHSA-vf5j-r2hw-2hrw is a missing authorization vulnerability in github.com/opencloud-eu/opencloud, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact

A security issue was discovered in [Reva](https://github.com/opencloud-eu/reva) that enables a malicious user to bypass the scope validation of a public link. That allows it to access resources outside the scope of a public link.

OpenCloud uses Reva as one of its core components and thus it is affected.

### Patches

Update to OpenCloud version >= 4.0.3 (stable release)
Update to OpenCloud version >= 5.0.2 (rolling release)

### Workarounds

If projects are unable to update immediately, please implement the following security configuration to disable public link shares temporarily until the final solution for this problem is rolled out.

#### Configuration Adjustment

* Docker Compose: Edit the docker-compose.yml and add `GATEWAY_STORAGE_PUBLIC_LINK_ENDPOINT=“”` (empty string value) in the `environment` section of the `opencloud` container.

#### Verification of Mitigation

Execute the following test: 
- Create a public link for testing. 
- Open the link url in a private (no active login) browser tab. 
- An error page with “unknown error” will be displayed.

This configuration provides immediate protection and should be implemented immediately. Configuration mitigation is available. It mitigates the problem completely.

### For more information

If there are questions or comments about this advisory:

- Security Support: [security@opencloud.eu](mailto:security@opencloud.eu)
- Technical Support: [support@opencloud.eu](mailto:support@opencloud.eu)

## Which versions are affected by GHSA-vf5j-r2hw-2hrw?

5 open source packages ship an affected version, including github.com/opencloud-eu/opencloud.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/opencloud-eu/opencloud` | Go | All versions | None |
| `github.com/opencloud-eu/opencloud` | Go | From 4.0.0 | 4.0.3 |
| `github.com/opencloud-eu/opencloud` | Go | From 4.0.0 | 4.0.3 |
| `github.com/opencloud-eu/opencloud` | Go | From 5.0.0 | 5.0.2 |
| `github.com/opencloud-eu/opencloud` | Go | From 5.0.0 | 5.0.2 |

## How do I fix GHSA-vf5j-r2hw-2hrw?

Upgrade github.com/opencloud-eu/opencloud to a fixed version for your release line: 4.0.3 or 5.0.2.

## Is GHSA-vf5j-r2hw-2hrw being exploited?

There is no known exploitation of GHSA-vf5j-r2hw-2hrw in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vf5j-r2hw-2hrw and fix it if it is affected.

What it is: GHSA-vf5j-r2hw-2hrw is a missing authorization vulnerability in github.com/opencloud-eu/opencloud, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-vf5j-r2hw-2hrw in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/opencloud-eu/opencloud (Go): affected all versions; no fix listed
- github.com/opencloud-eu/opencloud (Go): affected from 4.0.0; fixed in 4.0.3
- github.com/opencloud-eu/opencloud (Go): affected from 4.0.0; fixed in 4.0.3
- github.com/opencloud-eu/opencloud (Go): affected from 5.0.0; fixed in 5.0.2
- github.com/opencloud-eu/opencloud (Go): affected from 5.0.0; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vf5j-r2hw-2hrw/ (Markdown: https://insights.sbomify.com/GHSA-vf5j-r2hw-2hrw/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vf5j-r2hw-2hrw

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vf5j-r2hw-2hrw/
Summaries are generated and may contain mistakes; the official description above is the record.
