GHSA-vfpx-q664-h93m Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption
Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-vfpx-q664-h93m?
GHSA-vfpx-q664-h93m is a vulnerability in auth0/wordpress, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- It is using the Auth0 WordPress Plugin, versions between 5.0.0-BETA0 and 5.5.0
- Auth0 WordPress plugin using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.
Resolution
Upgrade Auth0/wordpress to version 5.6.0 or greater.
Which versions are affected by GHSA-vfpx-q664-h93m?
2 open source packages ship an affected version, including auth0/wordpress.
| Package | Affected | Fixed in |
|---|---|---|
auth0/wordpress Packagist | From 5.0.0-BETA0 | 5.6.0 |
auth0/wordpress Packagist | From 5.0.0-BETA0 | 5.6.0 |
How do I fix GHSA-vfpx-q664-h93m?
Upgrade auth0/wordpress to 5.6.0 or later.
Is GHSA-vfpx-q664-h93m being exploited?
There is no known exploitation of GHSA-vfpx-q664-h93m in the wild and no public exploit code.