{"answers":{"affected":"2 open source packages ship an affected version, including auth0/wordpress.","exploited":"There is no known exploitation of GHSA-vfpx-q664-h93m in the wild and no public exploit code.","fix":"Upgrade auth0/wordpress to 5.6.0 or later.","what":"GHSA-vfpx-q664-h93m is a vulnerability in auth0/wordpress, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vfpx-q664-h93m and fix it if it is affected.\n\nWhat it is: GHSA-vfpx-q664-h93m is a vulnerability in auth0/wordpress, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vfpx-q664-h93m in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/wordpress (Packagist): affected from 5.0.0-BETA0; fixed in 5.6.0\n- auth0/wordpress (Packagist): affected from 5.0.0-BETA0; fixed in 5.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vfpx-q664-h93m/ (Markdown: https://insights.sbomify.com/GHSA-vfpx-q664-h93m/index.md)","id":"GHSA-vfpx-q664-h93m","markdown":"https://insights.sbomify.com/GHSA-vfpx-q664-h93m/index.md","name":"GHSA-vfpx-q664-h93m","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nIn applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.\n\n### Am I Affected?\nConsumers are affected if their application meets the following preconditions:\n- It is using the Auth0 WordPress Plugin, versions between 5.0.0-BETA0 and 5.5.0\n- Auth0 WordPress plugin using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.\n\n### Resolution\nUpgrade Auth0/wordpress to version 5.6.0 or greater.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption","id":"GHSA-vfpx-q664-h93m","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.6.0"],"introduced":["5.0.0-BETA0"],"last_affected":[],"package":"auth0/wordpress","purl":null,"source":"GHSA-vfpx-q664-h93m"},{"ecosystem":"Packagist","fixed":["5.6.0"],"introduced":["5.0.0-BETA0"],"last_affected":[],"package":"auth0/wordpress","purl":"pkg:composer/auth0/wordpress","source":"GHSA-vfpx-q664-h93m"}],"products":null,"published":"2026-04-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.","url":"https://insights.sbomify.com/GHSA-vfpx-q664-h93m/"}