{"answers":{"affected":"4 open source packages ship an affected version, including @metamask/eth-ledger-bridge-keyring and eth-ledger-bridge-keyring.","exploited":"There is no known exploitation of GHSA-vg44-fw64-cpjx in the wild and no public exploit code.","fix":"Upgrade @metamask/eth-ledger-bridge-keyring to 0.2.2 or later.","what":"GHSA-vg44-fw64-cpjx is a vulnerability in @metamask/eth-ledger-bridge-keyring, published on 24 Mar 2020."},"fix_prompt":"Check this codebase for GHSA-vg44-fw64-cpjx and fix it if it is affected.\n\nWhat it is: GHSA-vg44-fw64-cpjx is a vulnerability in @metamask/eth-ledger-bridge-keyring, published on 24 Mar 2020. \nExploitation: There is no known exploitation of GHSA-vg44-fw64-cpjx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @metamask/eth-ledger-bridge-keyring (npm): affected all versions; fixed in 0.2.2\n- @metamask/eth-ledger-bridge-keyring (npm): affected all versions; fixed in 0.2.2\n- eth-ledger-bridge-keyring (npm): affected all versions; fixed in 0.2.1\n- eth-ledger-bridge-keyring (npm): affected all versions; fixed in 0.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vg44-fw64-cpjx/ (Markdown: https://insights.sbomify.com/GHSA-vg44-fw64-cpjx/index.md)","id":"GHSA-vg44-fw64-cpjx","markdown":"https://insights.sbomify.com/GHSA-vg44-fw64-cpjx/index.md","name":"GHSA-vg44-fw64-cpjx","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"unknown","non_default_config":true,"product_category":"Ledger keyring library","requires_auth":"none","summary":"Incorrect account selection during signing may cause transactions to be signed by the wrong key, requiring users to upgrade the library.","user_interaction":"required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nAnybody using this library to sign with a BIP44 account other than the first account may be affected. If a user is signing with the first account (i.e. the account at index `0`), or with the legacy MEW/MyCrypto HD path, they are not affected.\n\nThe vulnerability impacts cases where the user signs a personal message or transaction without first adding the account. This includes cases where the user has already added the account in a previous session (i.e. they added the account, reset the application, then signed something). The serialization/deserialization process does restore a previously added account, but it doesn\u0026#39;t restore the index instructing the keyring to use that account for signing. As a result, after serializing then deserializing the keyring state, the account at index `0` is always used for signing even if it isn\u0026#39;t the current account.\n\n### Patches\n\nThis has been patched ([#14](https://github.com/MetaMask/eth-ledger-bridge-keyring/pull/14)) in version \u0026gt;=0.2.1 of [`eth-ledger-bridge-keyring`](https://www.npmjs.com/package/eth-ledger-bridge-keyring), and in version \u0026gt;=0.2.2 of [`@metamask/eth-ledger-bridge-keyring`](https://www.npmjs.com/package/@metamask/eth-ledger-bridge-keyring). Users are encouraged to migrate to the new package name.\n\n### Workarounds\n\nTo work around this problem without updating, you should remove then re-add the account before use. As long as the account was added during the lifetime of that process, signing with that account should work correctly.\n\n### For more information\n\nIf you have any questions or comments about this advisory:\n\n* Open an issue in [MetaMask/eth-ledger-bridge-keyring on GitHub](https://github.com/MetaMask/eth-ledger-bridge-keyring)\n* Email the MetaMask team at [hello@metamask.io](mailto:hello@metamask.io)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Incorrect Account Used for Signing","id":"GHSA-vg44-fw64-cpjx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"@metamask/eth-ledger-bridge-keyring","purl":null,"source":"GHSA-vg44-fw64-cpjx"},{"ecosystem":"npm","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"@metamask/eth-ledger-bridge-keyring","purl":"pkg:npm/%40metamask/eth-ledger-bridge-keyring","source":"GHSA-vg44-fw64-cpjx"},{"ecosystem":"npm","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"eth-ledger-bridge-keyring","purl":null,"source":"GHSA-vg44-fw64-cpjx"},{"ecosystem":"npm","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"eth-ledger-bridge-keyring","purl":"pkg:npm/eth-ledger-bridge-keyring","source":"GHSA-vg44-fw64-cpjx"}],"products":null,"published":"2020-03-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Incorrect account selection during signing may cause transactions to be signed by the wrong key, requiring users to upgrade the library.","url":"https://insights.sbomify.com/GHSA-vg44-fw64-cpjx/"}