{"answers":{"affected":"3 open source packages ship an affected version, including github.com/authzed/spicedb.","exploited":"There is no known exploitation of GHSA-vhvq-fv9f-wh4q in the wild and no public exploit code.","fix":"Upgrade github.com/authzed/spicedb to 1.49.1 or later.","what":"GHSA-vhvq-fv9f-wh4q is a denial of service vulnerability in github.com/authzed/spicedb, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vhvq-fv9f-wh4q and fix it if it is affected.\n\nWhat it is: GHSA-vhvq-fv9f-wh4q is a denial of service vulnerability in github.com/authzed/spicedb, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vhvq-fv9f-wh4q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.49.1\n- github.com/authzed/spicedb (Go): affected from 1.29.3; fixed in 1.49.1\n- github.com/authzed/spicedb (Go): affected from 1.29.3; fixed in 1.49.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vhvq-fv9f-wh4q/ (Markdown: https://insights.sbomify.com/GHSA-vhvq-fv9f-wh4q/index.md)","id":"GHSA-vhvq-fv9f-wh4q","markdown":"https://insights.sbomify.com/GHSA-vhvq-fv9f-wh4q/index.md","name":"GHSA-vhvq-fv9f-wh4q","record":{"aliases":["GO-2026-4465"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SpiceDB authorization server","requires_auth":"low_privilege","summary":"An attacker with a valid token can crash the SpiceDB server by sending a malformed cursor token, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Description\nA malformed or tampered-with LookupResources [Cursor token](https://buf.build/authzed/api/docs/main:authzed.api.v1#authzed.api.v1.Cursor) can cause a panic in the SpiceDB process if it fails to parse. If an attacker were able to make requests to a SpiceDB instance, they could affect its availability.\n\n## Reproduction\nIf one was to take a cursor from a LookupResources call, decode it according to the logic that SpiceDB uses, and modify the Sections field to include an invalid relationship string, the process will panic.\n\n## Impact\nAn attacker would need both the ability to create a gRPC connection to your SpiceDB instance and a valid token, or else the ability to pass a cursor token from outside your application through to your SpiceDB instance.\n\nIf an attacker had this ability, they could bring down SpiceDB instances, reducing the availability of SpiceDB and any service that depends on it.\n\n## Mechanism\nThe SpiceDB process does not validate the contents of this `Sections` component of the `Cursor` message. In affected versions, it uses a parsing function that calls `panic` if the value cannot be parsed as a relationship. \n\n## Fix\nThis issue was fixed in https://github.com/authzed/spicedb/pull/2878.\n\n## Remediations\n* Prevent client control of the `optional_cursor` field in `LookupResources` calls\n* Upgrade to an unaffected version","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"LookupResources Cursor section tampering can crash SpiceDB process via tuple.MustParse panic","id":"GHSA-vhvq-fv9f-wh4q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["1.49.1"],"introduced":["0"],"last_affected":[],"package":"github.com/authzed/spicedb","purl":"pkg:golang/github.com/authzed/spicedb","source":"GO-2026-4465"},{"ecosystem":"Go","fixed":["1.49.1"],"introduced":["1.29.3"],"last_affected":[],"package":"github.com/authzed/spicedb","purl":null,"source":"GHSA-vhvq-fv9f-wh4q"},{"ecosystem":"Go","fixed":["1.49.1"],"introduced":["1.29.3"],"last_affected":[],"package":"github.com/authzed/spicedb","purl":"pkg:golang/github.com/authzed/spicedb","source":"GHSA-vhvq-fv9f-wh4q"}],"products":null,"published":"2026-02-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker with a valid token can crash the SpiceDB server by sending a malformed cursor token, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-vhvq-fv9f-wh4q/"}