{"answers":{"affected":"2 open source packages ship an affected version, including postiz.","exploited":"There is no known exploitation of GHSA-vj2p-7pgw-g2wf in the wild and no public exploit code.","fix":"No fix has been published for GHSA-vj2p-7pgw-g2wf yet. Limit exposure of the affected software until one is available.","what":"GHSA-vj2p-7pgw-g2wf is a server-side request forgery vulnerability in postiz, published on 27 Mar 2026. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-vj2p-7pgw-g2wf and fix it if it is affected.\n\nWhat it is: GHSA-vj2p-7pgw-g2wf is a server-side request forgery vulnerability in postiz, published on 27 Mar 2026. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-vj2p-7pgw-g2wf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postiz (npm): affected all versions up to 2.0.12; no fix listed\n- postiz (npm): affected all versions up to 2.0.12; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/ (Markdown: https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/index.md)","id":"GHSA-vj2p-7pgw-g2wf","markdown":"https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/index.md","name":"GHSA-vj2p-7pgw-g2wf","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Postiz App","requires_auth":"unknown","summary":"An SSRF vulnerability in Postiz App allows attackers to access internal network services and cloud metadata, potentially leaking credentials.","user_interaction":"unknown","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nA successful SSRF attack allows an attacker to:\n- Bypass firewalls to scan and interact with internal network services/ports.\n- Access sensitive cloud metadata services (e.g., AWS IMDS 169.254.169.254) to potentially leak instance credentials.\n- Pivot into the internal network environment where Postiz is hosted.\n\n### Workarounds\nThere are no workarounds known to this, please upgrade to Postiz version `v2.21.1`.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"Postiz App has a High-Severity SSRF Vulnerability via Next.js","id":"GHSA-vj2p-7pgw-g2wf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["2.0.12"],"package":"postiz","purl":null,"source":"GHSA-vj2p-7pgw-g2wf"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["2.0.12"],"package":"postiz","purl":"pkg:npm/postiz","source":"GHSA-vj2p-7pgw-g2wf"}],"products":null,"published":"2026-03-27","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An SSRF vulnerability in Postiz App allows attackers to access internal network services and cloud metadata, potentially leaking credentials.","url":"https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/"}