# GHSA-vj2p-7pgw-g2wf: Postiz App has a High-Severity SSRF Vulnerability via Next.js

> An SSRF vulnerability in Postiz App allows attackers to access internal network services and cloud metadata, potentially leaking credentials.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** No
- **Published:** 27 Mar 2026

## What is GHSA-vj2p-7pgw-g2wf?

GHSA-vj2p-7pgw-g2wf is a server-side request forgery vulnerability in postiz, published on 27 Mar 2026. It can be exploited over the network.

### Official description

### Impact
A successful SSRF attack allows an attacker to:
- Bypass firewalls to scan and interact with internal network services/ports.
- Access sensitive cloud metadata services (e.g., AWS IMDS 169.254.169.254) to potentially leak instance credentials.
- Pivot into the internal network environment where Postiz is hosted.

### Workarounds
There are no workarounds known to this, please upgrade to Postiz version `v2.21.1`.

## Which versions are affected by GHSA-vj2p-7pgw-g2wf?

2 open source packages ship an affected version, including postiz.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postiz` | npm | All versions to 2.0.12 | None |
| `postiz` | npm | All versions to 2.0.12 | None |

## How do I fix GHSA-vj2p-7pgw-g2wf?

No fix has been published for GHSA-vj2p-7pgw-g2wf yet. Limit exposure of the affected software until one is available.

## Is GHSA-vj2p-7pgw-g2wf being exploited?

There is no known exploitation of GHSA-vj2p-7pgw-g2wf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vj2p-7pgw-g2wf and fix it if it is affected.

What it is: GHSA-vj2p-7pgw-g2wf is a server-side request forgery vulnerability in postiz, published on 27 Mar 2026. It can be exploited over the network.
Exploitation: There is no known exploitation of GHSA-vj2p-7pgw-g2wf in the wild and no public exploit code.

Affected packages and fixed versions:
- postiz (npm): affected all versions up to 2.0.12; no fix listed
- postiz (npm): affected all versions up to 2.0.12; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/ (Markdown: https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vj2p-7pgw-g2wf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vj2p-7pgw-g2wf/
Summaries are generated and may contain mistakes; the official description above is the record.
