{"answers":{"affected":"2 open source packages ship an affected version, including doctrine/orm.","exploited":"There is no known exploitation of GHSA-vjrg-wpm8-rhrw in the wild and no public exploit code.","fix":"Upgrade doctrine/orm to 2.8.4 or later.","what":"GHSA-vjrg-wpm8-rhrw is a SQL injection vulnerability in doctrine/orm, published on 15 May 2024."},"fix_prompt":"Check this codebase for GHSA-vjrg-wpm8-rhrw and fix it if it is affected.\n\nWhat it is: GHSA-vjrg-wpm8-rhrw is a SQL injection vulnerability in doctrine/orm, published on 15 May 2024. \nExploitation: There is no known exploitation of GHSA-vjrg-wpm8-rhrw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- doctrine/orm (Packagist): affected from 2.8.3; fixed in 2.8.4\n- doctrine/orm (Packagist): affected from 2.8.3; fixed in 2.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vjrg-wpm8-rhrw/ (Markdown: https://insights.sbomify.com/GHSA-vjrg-wpm8-rhrw/index.md)","id":"GHSA-vjrg-wpm8-rhrw","markdown":"https://insights.sbomify.com/GHSA-vjrg-wpm8-rhrw/index.md","name":"GHSA-vjrg-wpm8-rhrw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"unknown","non_default_config":false,"product_category":"PHP ORM library","requires_auth":"unknown","summary":"Improper handling of case-insensitive checks in WHERE clauses may allow SQL injection, potentially exposing or modifying database data.","user_interaction":"unknown","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"An issue identified in doctrine/orm project related to statement in Where-Clause were not wrapped in brackets due to improper hadandling of case insensitive check.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"doctrine/orm Regression in Query Parenthesis can have Security Implications","id":"GHSA-vjrg-wpm8-rhrw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.8.4"],"introduced":["2.8.3"],"last_affected":[],"package":"doctrine/orm","purl":null,"source":"GHSA-vjrg-wpm8-rhrw"},{"ecosystem":"Packagist","fixed":["2.8.4"],"introduced":["2.8.3"],"last_affected":[],"package":"doctrine/orm","purl":"pkg:composer/doctrine/orm","source":"GHSA-vjrg-wpm8-rhrw"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Improper handling of case-insensitive checks in WHERE clauses may allow SQL injection, potentially exposing or modifying database data.","url":"https://insights.sbomify.com/GHSA-vjrg-wpm8-rhrw/"}