{"answers":{"affected":"4 open source packages ship an affected version, including pimcore/pimcore.","exploited":"There is no known exploitation of GHSA-vjwg-28gv-pm8h in the wild and no public exploit code.","fix":"Upgrade pimcore/pimcore to a fixed version for your release line: 11.1.6.5 or 11.2.3.","what":"GHSA-vjwg-28gv-pm8h is a cross-site scripting vulnerability in pimcore/pimcore, published on 24 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-vjwg-28gv-pm8h and fix it if it is affected.\n\nWhat it is: GHSA-vjwg-28gv-pm8h is a cross-site scripting vulnerability in pimcore/pimcore, published on 24 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-vjwg-28gv-pm8h in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected from 11.0.0-ALPHA1; fixed in 11.1.6.5\n- pimcore/pimcore (Packagist): affected from 11.0.0-ALPHA1; fixed in 11.1.6.5\n- pimcore/pimcore (Packagist): affected from 11.2.0; fixed in 11.2.3\n- pimcore/pimcore (Packagist): affected from 11.2.0; fixed in 11.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/ (Markdown: https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/index.md)","id":"GHSA-vjwg-28gv-pm8h","markdown":"https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/index.md","name":"GHSA-vjwg-28gv-pm8h","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore TinyMCE Bundle","requires_auth":"low_privilege","summary":"An XSS vulnerability in the TinyMCE editor allows attackers to execute arbitrary scripts, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThe TineMCE Bundle uses tinymce version 6.7.3. CVEs for this version exists for \u003c6.8.1:\nhttps://nvd.nist.gov/vuln/detail/CVE-2024-29203\nhttps://nvd.nist.gov/vuln/detail/CVE-2024-29881\n\n### Patches\nThe package should be updated to at least 6.8.1 to avoid XSS vulnerability.\n\n### Workarounds\nUpgrade pimcore to release 11.2.3 or 11.1.6.5.\n\n### References\nhttps://nvd.nist.gov/vuln/detail/CVE-2024-29203\nhttps://nvd.nist.gov/vuln/detail/CVE-2024-29881","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881","id":"GHSA-vjwg-28gv-pm8h","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["11.1.6.5"],"introduced":["11.0.0-ALPHA1"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-vjwg-28gv-pm8h"},{"ecosystem":"Packagist","fixed":["11.1.6.5"],"introduced":["11.0.0-ALPHA1"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-vjwg-28gv-pm8h"},{"ecosystem":"Packagist","fixed":["11.2.3"],"introduced":["11.2.0"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-vjwg-28gv-pm8h"},{"ecosystem":"Packagist","fixed":["11.2.3"],"introduced":["11.2.0"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-vjwg-28gv-pm8h"}],"products":null,"published":"2024-04-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in the TinyMCE editor allows attackers to execute arbitrary scripts, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/"}