# GHSA-vjwg-28gv-pm8h: Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881

> An XSS vulnerability in the TinyMCE editor allows attackers to execute arbitrary scripts, potentially leading to session hijacking or data theft.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Apr 2024

## What is GHSA-vjwg-28gv-pm8h?

GHSA-vjwg-28gv-pm8h is a cross-site scripting vulnerability in pimcore/pimcore, published on 24 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

### Impact
The TineMCE Bundle uses tinymce version 6.7.3. CVEs for this version exists for <6.8.1:
https://nvd.nist.gov/vuln/detail/CVE-2024-29203
https://nvd.nist.gov/vuln/detail/CVE-2024-29881

### Patches
The package should be updated to at least 6.8.1 to avoid XSS vulnerability.

### Workarounds
Upgrade pimcore to release 11.2.3 or 11.1.6.5.

### References
https://nvd.nist.gov/vuln/detail/CVE-2024-29203
https://nvd.nist.gov/vuln/detail/CVE-2024-29881

## Which versions are affected by GHSA-vjwg-28gv-pm8h?

4 open source packages ship an affected version, including pimcore/pimcore.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | From 11.0.0-ALPHA1 | 11.1.6.5 |
| `pimcore/pimcore` | Packagist | From 11.0.0-ALPHA1 | 11.1.6.5 |
| `pimcore/pimcore` | Packagist | From 11.2.0 | 11.2.3 |
| `pimcore/pimcore` | Packagist | From 11.2.0 | 11.2.3 |

## How do I fix GHSA-vjwg-28gv-pm8h?

Upgrade pimcore/pimcore to a fixed version for your release line: 11.1.6.5 or 11.2.3.

## Is GHSA-vjwg-28gv-pm8h being exploited?

There is no known exploitation of GHSA-vjwg-28gv-pm8h in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vjwg-28gv-pm8h and fix it if it is affected.

What it is: GHSA-vjwg-28gv-pm8h is a cross-site scripting vulnerability in pimcore/pimcore, published on 24 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-vjwg-28gv-pm8h in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected from 11.0.0-ALPHA1; fixed in 11.1.6.5
- pimcore/pimcore (Packagist): affected from 11.0.0-ALPHA1; fixed in 11.1.6.5
- pimcore/pimcore (Packagist): affected from 11.2.0; fixed in 11.2.3
- pimcore/pimcore (Packagist): affected from 11.2.0; fixed in 11.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/ (Markdown: https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vjwg-28gv-pm8h

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vjwg-28gv-pm8h/
Summaries are generated and may contain mistakes; the official description above is the record.
