# GHSA-vmg2-r3xv-r3xf: Simulation of Wasmd message can cause crashing


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Dec 2024
- **Also known as:** GO-2024-3319

## What is GHSA-vmg2-r3xv-r3xf?

GHSA-vmg2-r3xv-r3xf is a vulnerability in github.com/CosmWasm/wasmd, published on 10 Dec 2024. 

### Official description

# CWA-2024-009

**Severity**

Low (Marginal + Likely)[^1]

**Affected versions:**

- wasmd < 0.53.1

**Patched versions:**

- wasmd 0.53.2 (please note that wasmd 0.53.1 is broken and must not be used)

## Description of the bug

(Blank for now. We'll add more detail once chains had a chance to upgrade.)

## Mitigations

Apart from upgrading, it is recommended to **not** open the gRPC and REST APIs of _validator_ nodes to the public internet. Use isolated and resource-constrained environments for running separate public RPC nodes instead.
These can then easily be thrown away and replaced with new instances in case of problems.

## Applying the patch

### Official Wasmd patch

The patch will be shipped in a wasmd release. You will also have to update `libwasmvm` if you build statically.
If you already use the latest / close to latest wasmd, you can update more or less as follows:

1. Check the current wasmd version: `go list -m github.com/CosmWasm/wasmd`
2. Bump the `github.com/CosmWasm/wasmd` dependency in your go.mod to 0.53.2 (Cosmos SDK 0.50 compatible); `go mod tidy`; commit.
3. If you use the static libraries `libwasmvm_muslc.aarch64.a`/`libwasmvm_muslc.x86_64.a`, make sure that you use the same version as your wasmvm version.
4. Check the updated wasmd version: `go list -m github.com/CosmWasm/wasmd` and ensure you see 0.53.2.
5. Follow your regular practices to deploy chain upgrades.

To double check if the correct library version is loaded at runtime, use this query:
`<appd> query wasm libwasmvm-version`. It must show 2.1.4.

The patch is not consensus breaking _if you are already using wasmvm 2.1.3_.
If you are instead using wasmvm 2.1.2, then upgrading to 2.1.4 includes the consensus breaking changes of 2.1.3.

### DIY Patch

If you are unable to upgrade to the latest version, you can backport the wasmd patch to your version. The patch is available at [Wasmd 0.53.2](https://github.com/CosmWasm/wasmd/compare/v0.53.0...v0.53.2).
However, if you are on an older version of wasmd, you will also be using a different version of wasmvm. We provide the required patches for wasmvm in versions 2.1.4, 2.0.5, 1.5.6.
To upgrade using this method:

1. Check the current wasmvm version: `go list -m github.com/CosmWasm/wasmvm` and upgrade
   to the closest patched version.
2. Bump the github.com/CosmWasm/wasmvm dependency in your go.mod to the closest compatible patched version (either 2.1.4, 2.0.5 or 1.5.6); go mod tidy; commit.
3. Apply the patch linked above to your version of wasmd.
4. If you use the static libraries `libwasmvm_muslc.aarch64.a`/`libwasmvm_muslc.x86_64.a`, make sure that you use the same version as your wasmvm version.
5. Follow your regular practices to deploy chain upgrades.

To double check if the correct library version is loaded at runtime, use this query:
`<appd> query wasm libwasmvm-version`. It must show 2.1.4, 2.0.5 or 1.5.6 and must be the same as the wasmvm version in your go.sum.

The patch is not consensus breaking as long as you were using the previous patch version of wasmvm before.

## Acknowledgement

This issue was found by meadow101 who reported it to the Cosmos Bug Bounty Program on HackerOne.

If you believe you have found a bug in the Interchain Stack or would like to contribute to the
program by reporting a bug, please see <https://hackerone.com/cosmos>.

## Timeline

- 2024-09-25: Confio receives a report through the Cosmos bug bounty program maintained by Amulet.
- 2024-09-30: Confio security contributors confirm the report.
- 2024-11-21: Confio developed the patch internally.
- 2024-12-06: Patch release is pre-announced through notification lists.
- 2024-12-10: Patch released.

[^1]: following Amulet's Severity Classification Framework ACMv1: https://github.com/interchainio/security/blob/e0227a1fb4059144aab4f6003eeee7f09912db3a/resources/CLASSIFICATION_MATRIX.md

## Which versions are affected by GHSA-vmg2-r3xv-r3xf?

3 open source packages ship an affected version, including github.com/CosmWasm/wasmd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/CosmWasm/wasmd` | Go | All versions | 0.53.2 |
| `github.com/CosmWasm/wasmd` | Go | All versions | 0.53.2 |
| `github.com/CosmWasm/wasmd` | Go | All versions | 0.53.2 |

## How do I fix GHSA-vmg2-r3xv-r3xf?

Upgrade github.com/CosmWasm/wasmd to 0.53.2 or later.

## Is GHSA-vmg2-r3xv-r3xf being exploited?

There is no known exploitation of GHSA-vmg2-r3xv-r3xf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vmg2-r3xv-r3xf and fix it if it is affected.

What it is: GHSA-vmg2-r3xv-r3xf is a vulnerability in github.com/CosmWasm/wasmd, published on 10 Dec 2024. 
Exploitation: There is no known exploitation of GHSA-vmg2-r3xv-r3xf in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/CosmWasm/wasmd (Go): affected all versions; fixed in 0.53.2
- github.com/CosmWasm/wasmd (Go): affected all versions; fixed in 0.53.2
- github.com/CosmWasm/wasmd (Go): affected all versions; fixed in 0.53.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vmg2-r3xv-r3xf/ (Markdown: https://insights.sbomify.com/GHSA-vmg2-r3xv-r3xf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vmg2-r3xv-r3xf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vmg2-r3xv-r3xf/
Summaries are generated and may contain mistakes; the official description above is the record.
