# GHSA-vmqh-5232-v43r: Panic in wasmvm can slow down block production

> A panic in the CosmWasm VM library can slow down block production, causing a denial of service for blockchain networks using affected versions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2024

## What is GHSA-vmqh-5232-v43r?

GHSA-vmqh-5232-v43r is a denial of service vulnerability in github.com/CosmWasm/wasmvm, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

# CWA-2024-008

**Severity**

Medium (Moderate + Likely)[^1]

**Affected versions:**

- wasmvm >= 2.1.0, < 2.1.3
- wasmvm >= 2.0.0, < 2.0.4
- wasmvm < 1.5.5
- cosmwasm-vm >= 2.1.0, < 2.1.4
- cosmwasm-vm >= 2.0.0, < 2.0.7
- cosmwasm-vm < 1.5.8

**Patched versions:**

- wasmvm 1.5.5, 2.0.4, 2.1.3
- cosmwasm-vm 1.5.8, 2.0.7, 2.1.4

## Description of the bug

(Blank for now. We'll add more detail once chains had a chance to upgrade.)

## Patch

- 1.5: https://github.com/CosmWasm/cosmwasm/commit/edcdbc520d4f5521eed42de6e2869658278e91fd
- 2.0: https://github.com/CosmWasm/cosmwasm/commit/f63429ca59eb44dd5d780c1572016581337091e4
- 2.1: https://github.com/CosmWasm/cosmwasm/commit/108e7dcbf9c21df0fa83f355ad3a7355d7f220cb

## Applying the patch

The patch will be shipped in releases of wasmvm. You can update more or less as follows:

1. Check the current wasmvm version: `go list -m github.com/CosmWasm/wasmvm`
2. Bump the `github.com/CosmWasm/wasmvm` dependency in your go.mod to 1.5.5, 2.0.4, 2.1.3 depending on which minor version you are; `go mod tidy`; commit.
3. If you use the static libraries `libwasmvm_muslc.aarch64.a`/`libwasmvm_muslc.x86_64.a`, update them accordingly.
4. Check the updated wasmvm version: `go list -m github.com/CosmWasm/wasmvm` and ensure you see 1.5.5, 2.0.4, 2.1.3.
5. Follow your regular practices to deploy chain upgrades.

To double check if the correct library version is loaded at runtime, use this query:
`<appd> query wasm libwasmvm-version`. It must show 1.5.5, 2.0.4 or 2.1.3.

The patch is consensus breaking and requires a coordinated upgrade.

## Acknowledgement

This issue was found by meadow101 who reported it to the Cosmos Bug Bounty Program on HackerOne.

If you believe you have found a bug in the Interchain Stack or would like to contribute to the
program by reporting a bug, please see <https://hackerone.com/cosmos>.

## Timeline

- 2024-08-22: Confio receives a report through the Cosmos bug bounty program maintained by Amulet.
- 2024-08-23: Confio security contributors confirm the report.
- 2024-09-09: Confio developed the patch internally.
- 2024-09-23: Patch is released.

[^1]: following Amulet's Severity Classification Framework ACMv1: https://github.com/interchainio/security/blob/e0227a1fb4059144aab4f6003eeee7f09912db3a/resources/CLASSIFICATION_MATRIX.md

## Which versions are affected by GHSA-vmqh-5232-v43r?

12 open source packages ship an affected version, including github.com/CosmWasm/wasmvm/v2, github.com/CosmWasm/wasmvm and cosmwasm-vm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/CosmWasm/wasmvm/v2` | Go | From 2.0.0 | 2.0.4 |
| `github.com/CosmWasm/wasmvm/v2` | Go | From 2.0.0 | 2.0.4 |
| `github.com/CosmWasm/wasmvm/v2` | Go | From 2.1.0 | 2.1.3 |
| `github.com/CosmWasm/wasmvm/v2` | Go | From 2.1.0 | 2.1.3 |
| `github.com/CosmWasm/wasmvm` | Go | All versions | 1.5.5 |
| `github.com/CosmWasm/wasmvm` | Go | All versions | 1.5.5 |
| `cosmwasm-vm` | crates.io | All versions | 1.5.8 |
| `cosmwasm-vm` | crates.io | All versions | 1.5.8 |
| `cosmwasm-vm` | crates.io | From 2.0.0 | 2.0.7 |
| `cosmwasm-vm` | crates.io | From 2.0.0 | 2.0.7 |
| `cosmwasm-vm` | crates.io | From 2.1.0 | 2.1.4 |
| `cosmwasm-vm` | crates.io | From 2.1.0 | 2.1.4 |

## How do I fix GHSA-vmqh-5232-v43r?

Upgrade github.com/CosmWasm/wasmvm/v2 to a fixed version for your release line: 2.0.4 or 2.1.3.

## Is GHSA-vmqh-5232-v43r being exploited?

There is no known exploitation of GHSA-vmqh-5232-v43r in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vmqh-5232-v43r and fix it if it is affected.

What it is: GHSA-vmqh-5232-v43r is a denial of service vulnerability in github.com/CosmWasm/wasmvm, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-vmqh-5232-v43r in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/CosmWasm/wasmvm/v2 (Go): affected from 2.0.0; fixed in 2.0.4
- github.com/CosmWasm/wasmvm/v2 (Go): affected from 2.0.0; fixed in 2.0.4
- github.com/CosmWasm/wasmvm/v2 (Go): affected from 2.1.0; fixed in 2.1.3
- github.com/CosmWasm/wasmvm/v2 (Go): affected from 2.1.0; fixed in 2.1.3
- github.com/CosmWasm/wasmvm (Go): affected all versions; fixed in 1.5.5
- github.com/CosmWasm/wasmvm (Go): affected all versions; fixed in 1.5.5
- cosmwasm-vm (crates.io): affected all versions; fixed in 1.5.8
- cosmwasm-vm (crates.io): affected all versions; fixed in 1.5.8
- cosmwasm-vm (crates.io): affected from 2.0.0; fixed in 2.0.7
- cosmwasm-vm (crates.io): affected from 2.0.0; fixed in 2.0.7
- cosmwasm-vm (crates.io): affected from 2.1.0; fixed in 2.1.4
- cosmwasm-vm (crates.io): affected from 2.1.0; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vmqh-5232-v43r/ (Markdown: https://insights.sbomify.com/GHSA-vmqh-5232-v43r/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vmqh-5232-v43r

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vmqh-5232-v43r/
Summaries are generated and may contain mistakes; the official description above is the record.
