{"answers":{"affected":"2 open source packages ship an affected version, including swagger-ui.","exploited":"There is no known exploitation of GHSA-vp93-gcx5-4w52 in the wild and no public exploit code.","fix":"Upgrade swagger-ui to 2.2.1 or later.","what":"GHSA-vp93-gcx5-4w52 is a cross-site scripting vulnerability in swagger-ui, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-vp93-gcx5-4w52 and fix it if it is affected.\n\nWhat it is: GHSA-vp93-gcx5-4w52 is a cross-site scripting vulnerability in swagger-ui, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-vp93-gcx5-4w52 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- swagger-ui (npm): affected all versions; fixed in 2.2.1\n- swagger-ui (npm): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vp93-gcx5-4w52/ (Markdown: https://insights.sbomify.com/GHSA-vp93-gcx5-4w52/index.md)","id":"GHSA-vp93-gcx5-4w52","markdown":"https://insights.sbomify.com/GHSA-vp93-gcx5-4w52/index.md","name":"GHSA-vp93-gcx5-4w52","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in swagger-ui by injecting scripts into method descriptions, requiring user interaction to trigger.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `swagger-ui` prior to 2.2.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize JSON schemas, allowing attackers to execute arbitrary JavaScript using `\u003cscript\u003e` tags in the method descriptions.\n\n## Recommendation\n\nUpgrade to version 2.2.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in swagger-ui","id":"GHSA-vp93-gcx5-4w52","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"swagger-ui","purl":null,"source":"GHSA-vp93-gcx5-4w52"},{"ecosystem":"npm","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"swagger-ui","purl":"pkg:npm/swagger-ui","source":"GHSA-vp93-gcx5-4w52"}],"products":null,"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in swagger-ui by injecting scripts into method descriptions, requiring user interaction to trigger.","url":"https://insights.sbomify.com/GHSA-vp93-gcx5-4w52/"}