{"answers":{"affected":"2 open source packages ship an affected version, including canvas.","exploited":"There is no known exploitation of GHSA-vpq5-4rc8-c222 in the wild and no public exploit code.","fix":"Upgrade canvas to 1.6.10 or later.","what":"GHSA-vpq5-4rc8-c222 is a denial of service vulnerability in canvas, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vpq5-4rc8-c222 and fix it if it is affected.\n\nWhat it is: GHSA-vpq5-4rc8-c222 is a denial of service vulnerability in canvas, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vpq5-4rc8-c222 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- canvas (npm): affected all versions; fixed in 1.6.10\n- canvas (npm): affected all versions; fixed in 1.6.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vpq5-4rc8-c222/ (Markdown: https://insights.sbomify.com/GHSA-vpq5-4rc8-c222/index.md)","id":"GHSA-vpq5-4rc8-c222","markdown":"https://insights.sbomify.com/GHSA-vpq5-4rc8-c222/index.md","name":"GHSA-vpq5-4rc8-c222","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js canvas library","requires_auth":"none","summary":"An attacker can crash the Node.js process by sending malicious JPEG or GIF images to applications using the canvas library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `canvas` prior to 1.6.10 are vulnerable to Denial of Service. Processing malicious JPEGs or GIFs could crash the node process.\n\n## Recommendation\n\nUpgrade to version 1.6.10","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in canvas","id":"GHSA-vpq5-4rc8-c222","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.6.10"],"introduced":["0"],"last_affected":[],"package":"canvas","purl":null,"source":"GHSA-vpq5-4rc8-c222"},{"ecosystem":"npm","fixed":["1.6.10"],"introduced":["0"],"last_affected":[],"package":"canvas","purl":"pkg:npm/canvas","source":"GHSA-vpq5-4rc8-c222"}],"products":null,"published":"2019-06-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash the Node.js process by sending malicious JPEG or GIF images to applications using the canvas library.","url":"https://insights.sbomify.com/GHSA-vpq5-4rc8-c222/"}